Last Comment Bug 735517 - Web Apps icon always appears when other popup notifications appear
: Web Apps icon always appears when other popup notifications appear
Status: VERIFIED FIXED
: regression
Product: Firefox Graveyard
Classification: Graveyard
Component: Web Apps (show other bugs)
: Trunk
: All All
: -- normal
: Firefox 14
Assigned To: Nobody; OK to take it and work on it
: Jason Smith [:jsmith]
Mentors:
Depends on:
Blocks: 697006
  Show dependency treegraph
 
Reported: 2012-03-13 16:28 PDT by Tetsuharu OHZEKI [:tetsuharu] [UTC+9]
Modified: 2016-02-04 15:00 PST (History)
8 users (show)
jsmith: in‑moztrap-
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
proposed patch (1.05 KB, text/plain)
2012-03-13 16:37 PDT, Tetsuharu OHZEKI [:tetsuharu] [UTC+9]
no flags Details
proposed patch (1.05 KB, patch)
2012-03-13 16:38 PDT, Tetsuharu OHZEKI [:tetsuharu] [UTC+9]
fabrice: review+
dao+bmo: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-03-13 16:28:58 PDT
Enviroment:
Windows 7 (x64)
http://hg.mozilla.org/mozilla-central/rev/8d1c74566a0b

STR:
Show popup notification. (e.g. http://maps.google.com/ 's geolocation)

Result:
Show web app notification icon.

This bug is caused by http://hg.mozilla.org/mozilla-central/rev/374977a5f8c6.
So the following code is wrong. This element's class attribute should be "notification-anchor-icon".

/browser/base/content/browser.xul

<image id="webapps-notification-icon" class="webapps-anchor-icon" role="button"/>
Comment 1 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-03-13 16:37:51 PDT
Created attachment 605591 [details]
proposed patch
Comment 2 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-03-13 16:38:21 PDT
Created attachment 605592 [details] [diff] [review]
proposed patch
Comment 3 [:fabrice] Fabrice Desré 2012-03-13 16:46:32 PDT
nice catch!
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-03-14 09:24:50 PDT
*** Bug 735680 has been marked as a duplicate of this bug. ***
Comment 5 :Felipe Gomes (needinfo me!) 2012-03-14 14:17:07 PDT
Thanks Ohzeki.

http://hg.mozilla.org/mozilla-central/rev/629298cfd480
Comment 6 :Felipe Gomes (needinfo me!) 2012-03-14 14:19:28 PDT
Comment on attachment 605592 [details] [diff] [review]
proposed patch

[Approval Request Comment]
This bug is present in Aurora since it landed before the uplift yesterday. Simple patch to fix the webapps icon showing during unrelated popup notifications
Comment 7 Alex Keybl [:akeybl] 2012-03-15 14:36:49 PDT
Comment on attachment 605592 [details] [diff] [review]
proposed patch

[Triage Comment]
Low risk fix in support of webapp notifications. Approved for Aurora 13.
Comment 8 :Felipe Gomes (needinfo me!) 2012-03-15 14:53:36 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/663a0383af8d
Comment 9 Jason Smith [:jsmith] 2012-04-15 14:46:47 PDT
Verified on Nightly.
Comment 10 Jason Smith [:jsmith] 2012-04-15 14:54:02 PDT
Also verified on Aurora.

Note You need to log in before you can comment on or make changes to this bug.