Last Comment Bug 735536 - B2G SMS DB: Use new fangled IndexedDB string constants
: B2G SMS DB: Use new fangled IndexedDB string constants
Status: RESOLVED FIXED
[good first bug][lang=js][mentor=phil...
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: ARM Gonk (Firefox OS)
: -- normal (vote)
: mozilla14
Assigned To: Fernando Jiménez Moreno [:ferjm]
:
Mentors:
: 736009 736376 (view as bug list)
Depends on: 735094
Blocks: 712809 736376
  Show dependency treegraph
 
Reported: 2012-03-13 17:37 PDT by Philipp von Weitershausen [:philikon]
Modified: 2012-11-14 05:19 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix v1 (7.87 KB, patch)
2012-03-15 04:01 PDT, Fernando Jiménez Moreno [:ferjm]
no flags Details | Diff | Review
Fix v1 (7.87 KB, patch)
2012-03-15 09:06 PDT, Fernando Jiménez Moreno [:ferjm]
philipp: feedback+
Details | Diff | Review
Fix v2 (8.57 KB, patch)
2012-03-16 12:15 PDT, Fernando Jiménez Moreno [:ferjm]
philipp: review+
Details | Diff | Review

Description Philipp von Weitershausen [:philikon] 2012-03-13 17:37:21 PDT
See bug 735094.
Comment 1 Philipp von Weitershausen [:philikon] 2012-03-13 17:38:08 PDT
Also c.f. bug 735357 for inspiration (not that the fix is that complicated...)
Comment 2 Philipp von Weitershausen [:philikon] 2012-03-15 02:41:11 PDT
*** Bug 736009 has been marked as a duplicate of this bug. ***
Comment 3 Fernando Jiménez Moreno [:ferjm] 2012-03-15 04:01:44 PDT
Created attachment 606155 [details] [diff] [review]
Fix v1
Comment 4 Fernando Jiménez Moreno [:ferjm] 2012-03-15 09:06:35 PDT
Created attachment 606244 [details] [diff] [review]
Fix v1

Sorry, the patch was corrupted and wouldn´t apply.
Comment 5 Philipp von Weitershausen [:philikon] 2012-03-15 16:49:31 PDT
Comment on attachment 606244 [details] [diff] [review]
Fix v1

I would actually prefer if we const'ed those values, e.g.:

  const READONLY = "readonly";

etc. Looks good otherwise!
Comment 6 Fernando Jiménez Moreno [:ferjm] 2012-03-16 12:15:19 PDT
Created attachment 606669 [details] [diff] [review]
Fix v2

Yes, I thought about the constants, but the ContactDB patch didn´t use constants, so I chose to also don´t use it. Anyway, I also prefer this way.
Comment 7 Philipp von Weitershausen [:philikon] 2012-03-16 17:24:53 PDT
https://hg.mozilla.org/mozilla-central/rev/c0e783b4cc4b
Comment 8 Vicamo Yang [:vicamo][:vyang] 2012-11-14 05:19:43 PST
*** Bug 736376 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.