Last Comment Bug 735556 - Data-URI with WOFF web font and @font-face not working
: Data-URI with WOFF web font and @font-face not working
Status: VERIFIED INVALID
:
Product: Core
Classification: Components
Component: Layout: Text (show other bugs)
: 10 Branch
: x86_64 All
: -- minor (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 19:44 PDT by Laurent Bourgault-Roy
Modified: 2012-04-25 02:14 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Example file for the described behavior. (69.05 KB, text/html)
2012-03-13 19:44 PDT, Laurent Bourgault-Roy
no flags Details

Description Laurent Bourgault-Roy 2012-03-13 19:44:23 PDT
Created attachment 605637 [details]
Example file for the described behavior.

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

I tried to use the font-face attribute with a woff font, but instead of linking to an external resource, I directly embedded the font in the web page using a data URI.


Actual results:

The font wasn't used in the rendering, instead falling back to a standard font. Safari, Chrome and IE9 displayed the font correctly.


Expected results:

Firefox should correctly display the embedded font
Comment 1 Matthias Versen [:Matti] 2012-03-13 19:54:22 PDT
Error: downloadable font: rejected by sanitizer (font-family: "Lato-Light" style:normal weight:normal stretch:normal src index:0)
Comment 2 Jonathan Kew (:jfkthame) 2012-03-14 04:43:00 PDT
Check the woff file with Tal Leming's woff validator (see http://code.typesupply.com/wiki/woffTools), and I think you'll find that it has an error.

Then report the problem as a bug against whatever woff-production tool was used to create it. I believe Firefox is correct to reject the resource as invalid.
Comment 3 Laurent Bourgault-Roy 2012-03-14 07:21:49 PDT
Alright then. It is weird though that IE and Safari accept it. Thank you for checking it out.
Comment 4 Jonathan Kew (:jfkthame) 2012-03-14 09:45:01 PDT
This just means they're not validating the data as carefully. I expect they will be updated in due course, as the WOFF conformance test suite requires browsers to reject malformed files. Chrome, in particular, will probably reject it soon, as it uses the same font validation library as Firefox (though sometimes one or the other may be more up-to-date).
Comment 5 THE:// 2012-04-24 09:12:14 PDT
Meybe more example:

its started from Firefox 4

http://fortawesome.github.com/Font-Awesome/

etc 

I know about 20 pages that fonts not work on Firefox correctly and in some pages
there are popup message please use Chrome because Firefox is buqy.
Comment 6 Matthias Versen [:Matti] 2012-04-24 13:52:27 PDT
This bug report is about _one_ specific font. This font is broken and the bug is marked invalid.
Comment 7 THE:// 2012-04-24 14:17:06 PDT
Go to:

http://www.fontsquirrel.com/fontface/generator

Create font eq woff by using Base64 encoding

its only broken in Firefox so Firefox is buqqy.

All pages for generate base64 font make the same base64 string but only Firefox cant handle this.

___

Remember please one thing Netscape whose **** for "web-developers" because if you had broken code no valid by "The W3C" specification, webpage not render correctly. Internet explorer has lot of hack for perfect rendering page this is reasons why people use it in past. 

And now people use Chrome because its render perfect page. Developer use it because Mozilla canot repair buq from 2002 eq "page break" etc. 

And you now What Chrome has implemented "command line printing" + PDF one weak after you remove this feature from Firefox.

Stave belmer says
Developer Developer Developer Developer

Mozilla say:
F... webdeveloper F... webdeveloper  F... webdeveloper  F... webdeveloper 
since 2002
Comment 8 Andre Klapper 2012-04-25 02:14:49 PDT
THE://:
It looks like you did not understand comment 6, so please read it again. And again.
Please go to a random forum for your off-topic rants. This is a bugtracker so stay technical and respectful. Otherwise your account will be quickly disabled.

Note You need to log in before you can comment on or make changes to this bug.