Last Comment Bug 735615 - Remove AutoClean from mozglue/linker/Utils.h
: Remove AutoClean from mozglue/linker/Utils.h
Status: RESOLVED FIXED
[mentor=Yoric][lang=c++]
:
Product: Core
Classification: Components
Component: mozglue (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: mozilla17
Assigned To: Andrew Quartey [:drexler]
: mozglue
Mentors:
Depends on: 718938 826173
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 03:11 PDT by David Rajchenbach-Teller [:Yoric] (please use "needinfo")
Modified: 2013-01-03 01:06 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (12.65 KB, patch)
2012-07-28 11:04 PDT, Andrew Quartey [:drexler]
mh+mozilla: review+
Details | Diff | Review

Description David Rajchenbach-Teller [:Yoric] (please use "needinfo") 2012-03-14 03:11:47 PDT
Now that we have generic RAII helpers in MFBT, we should get rid of the corresponding original code in mozglue/linker/Utils.h, which does not compile with VC++.
Comment 1 David Rajchenbach-Teller [:Yoric] (please use "needinfo") 2012-03-14 05:50:43 PDT
Note: to test that it does not break faulty.lib, add |export MOZ_LINKER=1| to mozconfig and build on Linux desktop.
Comment 2 David Rajchenbach-Teller [:Yoric] (please use "needinfo") 2012-03-15 05:06:15 PDT
Actually, it looks like a good candidate for mentored bugs.
Comment 3 Andrew Quartey [:drexler] 2012-07-28 11:04:04 PDT
Created attachment 646882 [details] [diff] [review]
patch
Comment 4 Mike Hommey [:glandium] 2012-07-29 00:55:01 PDT
Comment on attachment 646882 [details] [diff] [review]
patch

I'll take this review
Comment 5 Andrew Quartey [:drexler] 2012-07-30 11:24:14 PDT
Sent to inbound: https://hg.mozilla.org/integration/mozilla-inbound/rev/3c34aa0c81f7
Comment 6 Ed Morley [:emorley] 2012-07-31 06:12:45 PDT
https://hg.mozilla.org/mozilla-central/rev/3c34aa0c81f7

Note You need to log in before you can comment on or make changes to this bug.