Last Comment Bug 735625 - Get rid of ImportHTMLFromFileToFolder
: Get rid of ImportHTMLFromFileToFolder
Status: RESOLVED FIXED
: addon-compat, dev-doc-complete
Product: Toolkit
Classification: Components
Component: Places (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla14
Assigned To: Marco Bonardo [::mak] (Away 6-20 Aug)
:
Mentors:
Depends on: 735312
Blocks: 482911 736547
  Show dependency treegraph
 
Reported: 2012-03-14 03:52 PDT by Marco Bonardo [::mak] (Away 6-20 Aug)
Modified: 2012-04-29 13:48 PDT (History)
5 users (show)
mak77: in‑testsuite-
mak77: in‑litmus-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1.0 (9.85 KB, patch)
2012-03-14 17:40 PDT, Marco Bonardo [::mak] (Away 6-20 Aug)
dietrich: review+
gavin.sharp: superreview+
Details | Diff | Splinter Review

Description Marco Bonardo [::mak] (Away 6-20 Aug) 2012-03-14 03:52:48 PDT
bug 735312 is removing the last caller, to this method can die.
Comment 1 Marco Bonardo [::mak] (Away 6-20 Aug) 2012-03-14 17:40:07 PDT
Created attachment 606038 [details] [diff] [review]
patch v1.0

Note that I could do much more cleanup than this, since some internal methods have redundant arguments now.  Though, since the rewrite from hsivonen is pending review and I already commented on some of those there in my last review pass, it's not worth putting more stuff here.  This removal will instead simplify things there, by killing code and clarifying what is left.
Comment 2 Marco Bonardo [::mak] (Away 6-20 Aug) 2012-03-15 16:14:08 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/8dcabd1aa9c7

Setting addon-compat for the method removal, even if the probability someone uses this is quite low.
Comment 3 Marco Bonardo [::mak] (Away 6-20 Aug) 2012-03-15 16:14:38 PDT
and dev-doc-needed in case the interface page needs update
Comment 4 Marco Bonardo [::mak] (Away 6-20 Aug) 2012-03-16 06:27:09 PDT
https://hg.mozilla.org/mozilla-central/rev/8dcabd1aa9c7
Comment 5 Eric Shepherd [:sheppy] 2012-04-29 13:48:30 PDT
Documentation tweaked:

https://developer.mozilla.org/En/Places_Developer_Guide#HTML_Import.2FExport

The interface wasn't documented at all, but now it is, with these changes noted:

https://developer.mozilla.org/en/XPCOM_Interface_Reference/nsIPlacesImportExportService

Mentioned on Firefox 14 for developers.

Note You need to log in before you can comment on or make changes to this bug.