Panning is possible while html5 videos are in fullscreen after rotating the device from landscape to portrait

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: AdrianT, Assigned: kats)

Tracking

(Blocks: 1 bug)

13 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 -)

Details

(Whiteboard: [viewport])

(Reporter)

Description

7 years ago
Fennec/13.0a1 2012-03-13
Device: HTC Desire (Android 2.2.2)

Steps to reproduce:
1. Open Nightly.
2. Set the device in landscape mode.
3. Go to http://introducinghtml5.com/examples/ch04/ch4-full-fallback.html.
4. Set the video to fullscreen.
5. After playback starts, rotate the device to portrait mode.
6. Try to pan the video.

Expected results:
Since the video is in fullscreen panning/zooming is impossible.

Actual results:
The video is not resized to fit the portrait mode (zoomed out) and the user can pan the video that is now bigger then the screen.
Related to bug 730087?
(Reporter)

Comment 2

7 years ago
On Nightly/14.0a1 2012-03-27 on Motorola Droid 2 ( Android 2.3)the video is still zoomed but now it can't be paned but the zoom level can be changed.
blocking-fennec1.0: --- → ?
Whiteboard: [viewport]
blocking-fennec1.0: ? → +
(Reporter)

Comment 3

7 years ago
On Nightly/14.0a1 2012-04-11 panning is still not possible but the position is still changed on rotation leaving the video offscreen. Maybe we should close this issue and cover the new behavior in a new bug?
Related to bug 737021?
blocking-fennec1.0: + → -
Assignee: nobody → bugmail.mozilla
Component: General → Graphics, Panning and Zooming
Blocks: 800673
This is basically a dupe of bug 771112, except with a URL that doesn't exist any more. I tried reproducing on a different HTML5 video and wasn't able to. Tested on the HTC Desire HD and Galaxy Nexus running recent nightlies (FF 20).
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.