Last Comment Bug 735660 - Fix db migrations in BrowserProvider
: Fix db migrations in BrowserProvider
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All Android
: -- normal (vote)
: Firefox 14
Assigned To: Lucas Rocha (:lucasr)
:
Mentors:
Depends on:
Blocks: 708149
  Show dependency treegraph
 
Reported: 2012-03-14 07:08 PDT by Lucas Rocha (:lucasr)
Modified: 2012-03-24 09:18 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
beta+


Attachments
(1/2) Commit DB transaction used by migrations (1004 bytes, patch)
2012-03-14 07:13 PDT, Lucas Rocha (:lucasr)
mark.finkle: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review
(2/2) Bump database version to enable more performant views (1.14 KB, patch)
2012-03-14 07:13 PDT, Lucas Rocha (:lucasr)
mark.finkle: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Lucas Rocha (:lucasr) 2012-03-14 07:08:45 PDT
Two issues:
- Migration to activate history/bookmarks view with images (with no sub-selected) was never active because the db version was not bumped.
- Migrations are simply no being committed because it's missing setTransactionSuccessful() call.
Comment 1 Lucas Rocha (:lucasr) 2012-03-14 07:13:21 PDT
Created attachment 605737 [details] [diff] [review]
(1/2) Commit DB transaction used by migrations
Comment 2 Lucas Rocha (:lucasr) 2012-03-14 07:13:30 PDT
Created attachment 605738 [details] [diff] [review]
(2/2) Bump database version to enable more performant views
Comment 5 Lucas Rocha (:lucasr) 2012-03-21 08:43:59 PDT
This is a hard dependency to land bug 708149 in Aurora btw. So, this is almost automatically a beta blocker as well.
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2012-03-21 08:46:05 PDT
Ageed. Please ask for aurora approval.
Comment 7 Lucas Rocha (:lucasr) 2012-03-21 08:47:22 PDT
Comment on attachment 605737 [details] [diff] [review]
(1/2) Commit DB transaction used by migrations

Mobile-only. Beta blocker.
Comment 8 Lucas Rocha (:lucasr) 2012-03-21 08:47:27 PDT
Comment on attachment 605738 [details] [diff] [review]
(2/2) Bump database version to enable more performant views

Mobile-only. Beta blocker.
Comment 9 Lukas Blakk [:lsblakk] use ?needinfo 2012-03-21 14:58:12 PDT
[Triage Comment]
Can we get a risk assessment here? There have been many issues lately with bookmarks (see https://wiki.mozilla.org/Firefox/Planning/2012-03-21#Desktop), will this help?
Comment 10 Mark Finkle (:mfinkle) (use needinfo?) 2012-03-21 15:11:57 PDT
(In reply to Lukas Blakk [:lsblakk] from comment #9)
> [Triage Comment]
> Can we get a risk assessment here? There have been many issues lately with
> bookmarks (see
> https://wiki.mozilla.org/Firefox/Planning/2012-03-21#Desktop), will this
> help?

This change has nothing to do with Sync. This change merely makes sure the DB is updated to the newer version. The version that has a much faster awesomebar query. It is a blocker for Fennec13 too.
Comment 11 Lukas Blakk [:lsblakk] use ?needinfo 2012-03-21 15:15:13 PDT
Comment on attachment 605737 [details] [diff] [review]
(1/2) Commit DB transaction used by migrations

[Triage Comment]
Sorry, just caught that this is a Fennec Native bug, please ignore previous comment and go ahead with this.

Note You need to log in before you can comment on or make changes to this bug.