crash [@ nsIDocument::GetContainer() ]

VERIFIED FIXED in Firefox 12

Status

()

Core
Disability Access APIs
--
critical
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: MarcoZ, Assigned: surkov)

Tracking

({crash, regression})

12 Branch
mozilla14
All
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(firefox12 verified, firefox13 verified)

Details

(Whiteboard: [qa!], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
+++ This bug was initially created as a clone of Bug #597963 +++

It reappeared in Firefox 12.0a2 and was reported to me by a community member. However since that is on Windows where the original bug was on Linux, creating a new report for it. The report is:
https://crash-stats.mozilla.com/report/index/bp-cd712733-aaae-4bd1-b282-923d82120304
(Reporter)

Comment 1

6 years ago
And another report:
https://crash-stats.mozilla.com/report/index/bp-7c979555-4aed-4d82-ba64-4c9802120301
(Assignee)

Comment 2

6 years ago
it appears we shutdown the shutdown document
(Assignee)

Comment 3

6 years ago
Created attachment 605820 [details] [diff] [review]
patch
Assignee: nobody → surkov.alexander
Status: NEW → ASSIGNED
Attachment #605820 - Flags: review?(trev.saunders)

Comment 4

6 years ago
It's #35 top browser crasher in 12.0a2.
status-firefox12: --- → affected
status-firefox13: --- → affected
No longer depends on: 597963
Keywords: regression
Attachment #605820 - Flags: review?(trev.saunders) → review+
(Assignee)

Comment 5

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/5392a82cabeb
(Assignee)

Comment 6

6 years ago
Marco, could you keep an eye on the bug and port the patch to branches?
https://hg.mozilla.org/mozilla-central/rev/5392a82cabeb
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla14
(Reporter)

Comment 8

6 years ago
Comment on attachment 605820 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): unknown
User impact if declined: Crashes
Testing completed (on m-c, etc.): Yes
Risk to taking this patch (and alternatives if risky):None (two defunct tests)
String changes made by this patch:None
Attachment #605820 - Flags: approval-mozilla-aurora?
(Reporter)

Comment 9

6 years ago
Comment on attachment 605820 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): unknown
User impact if declined: frequent crashes
Testing completed (on m-c, etc.): Yes
Risk to taking this patch (and alternatives if risky):none (two defunct checks)
String changes made by this patch:none
Attachment #605820 - Flags: approval-mozilla-beta?
Comment on attachment 605820 [details] [diff] [review]
patch

[Triage Comment]
Low risk, first appearing in Firefox 12. Approved for Beta 12 and Aurora 13.
Attachment #605820 - Flags: approval-mozilla-beta?
Attachment #605820 - Flags: approval-mozilla-beta+
Attachment #605820 - Flags: approval-mozilla-aurora?
Attachment #605820 - Flags: approval-mozilla-aurora+
(Reporter)

Comment 11

6 years ago
Landed on Aurora on surkov's behalf: http://hg.mozilla.org/releases/mozilla-aurora/rev/1441fec02ec6
status-firefox13: affected → fixed
(Reporter)

Comment 12

6 years ago
Landed on mozilla-beta on surkov's behalf: https://hg.mozilla.org/releases/mozilla-beta/rev/ad869b73e5b9
status-firefox12: affected → fixed
Is there a testcase for this bug or is it simply a matter of checking crashstats?
Whiteboard: [qa?]
2012032604 is this last build so far that is showing crashes in this signature.
(Reporter)

Comment 15

6 years ago
It is oly a matter of checking crash-stats, esp for Aurora and Beta now.

Comment 16

6 years ago
The latest crash in Aurora happened with 13.0a2/20120326042011.
Let's wait for Beta as 12.0b3 is not yet released.
status-firefox13: fixed → verified
Whiteboard: [qa?] → [qa+]
The latest crash in Beta was with the build 20120321033733 (12.0b2); no crashes were reported with 12.0b3 build.
Marking this verified for Beta, as well.
Also, no crashes were found on Nightly (14.0a1) builds, either.
Status: RESOLVED → VERIFIED
status-firefox12: fixed → verified
Whiteboard: [qa+] → [qa!]
You need to log in before you can comment on or make changes to this bug.