If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

AttributeError: 'NoneType' object has no attribute 'file_path' (in mkt.developers.tasks.fetch_icon)

RESOLVED DUPLICATE of bug 735884

Status

addons.mozilla.org Graveyard
Developer Pages
RESOLVED DUPLICATE of bug 735884
6 years ago
2 years ago

People

(Reporter: kumar, Assigned: ashort)

Tracking

unspecified
6.4.8
x86
Mac OS X

Details

Task mkt.developers.tasks.fetch_icon with id 00779415-3c31-49b9-b4b8-dc909b314695 raised exception:
'AttributeError("\'NoneType\' object has no attribute \'file_path\'",)'


Task was called with args: (<Webapp: 367695: Projeqt>,) kwargs: {}.

The contents of the full traceback was:

Traceback (most recent call last):
 File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/celery/execute/trace.py", line 34, in trace
   return cls(states.SUCCESS, retval=fun(*args, **kwargs))
 File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/celery/task/base.py", line 241, in __call__
   return self.run(*args, **kwargs)
 File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/celery/app/__init__.py", line 141, in run
   return fun(*args, **kwargs)
 File "/data/www/addons.mozilla.org/zamboni/vendor/src/nuggets/celeryutils.py", line 35, in wrapped
   return fun(*args, **kw)
 File "/data/www/addons.mozilla.org/zamboni/mkt/developers/tasks.py", line 317, in fetch_icon
   manifest = webapp.get_manifest_json()
 File "/data/www/addons.mozilla.org/zamboni/apps/webapps/models.py", line 140, in get_manifest_json
   with open(self.get_latest_file().file_path, 'r') as mf:
AttributeError: 'NoneType' object has no attribute 'file_path'
looks like one of the submission views is missing a transaction
Target Milestone: --- → 6.4.6
we should transact/catch/something this.  Do what is best.
Assignee: nobody → ashort
Target Milestone: 6.4.6 → 6.4.8
This has only happened three times so I am pretty sure it is due to slave lag which will be fixed in bug 735884. In most places this task is called, it is called immediately after a DB write.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 735884
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.