Multiple words makes "Messages including:" in Global Search Bar go blank

RESOLVED FIXED

Status

Mozilla Localizations
sv-SE / Swedish
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Mikael Hiort af Ornäs, Assigned: u60234)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 605785 [details]
globalsearchtabsontop-sv-SE.png

User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

Entered text into the Thunderbird global search bar (TB 11, locale: sv-SE). The problem occurred in both an add-on free and an add-on rich environment.


Actual results:

If I only enter one word into the search text box, both the "Messages including:" and the "Search the web for:" drop-down menu options show the entered search term.

However, if I enter more words, space separated, the "Messages including:" no longer shows the entered words as they should (see attached image file). When clicking that option the message search tab opens, but has only recognised the last word entered in the search box.


Expected results:

Normally the the "Messages including:" menu option shows all the words in the search string, separated by commas. The results tab for that option should also include all the entered search terms, not just the last one.
This is a problem for the sv-SE locale only. Looks like the string was miss-translated:

http://hg.mozilla.org/releases/l10n/mozilla-beta/sv-SE/file/750845bf8479/mail/chrome/messenger/glodaComplete.properties#l53

glodaComplete.messagesMentioningMany.label=Meddelanden som innehåller:

should be

glodaComplete.messagesMentioningMany.label=Meddelanden som innehåller: #1

The #1 is missing.
Assignee: nobody → hasse
Status: UNCONFIRMED → NEW
Component: Search → sv-SE / Swedish
Ever confirmed: true
Product: Thunderbird → Mozilla Localizations
QA Contact: search → slicedlime
Version: 11 → unspecified
(Assignee)

Comment 2

6 years ago
Oops, thanks for finding this.

Fixed in central, aurora and beta.

http://hg.mozilla.org/l10n-central/sv-SE/rev/cdba769ebcff
http://hg.mozilla.org/releases/l10n/mozilla-aurora/sv-SE/rev/77f0d3978d64
http://hg.mozilla.org/releases/l10n/mozilla-beta/sv-SE/rev/4ed131758614
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.