Make mozilla.support.calendar moderated

RESOLVED FIXED

Status

mozilla.org
Discussion Forums
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: cilias, Assigned: mburns)

Tracking

Details

(Whiteboard: [waiting for Giganews])

(Reporter)

Description

5 years ago
In bug 635078, the new support newsgroup configuration was applied to mozilla.support.other, and we tested the spam filter in bug 663318. I think we're now ready to apply that configuration to rest of the support newsgroups. mozilla.support.calendar is a low-traffic group we can apply this to before applying it to the firefox and thunderbird support newsgroups.

I just need the group set as moderated, the same way other moderated Mozilla newsgroups are configured. The rest I can do via the list admin UI.
Who will be doing the moderation? Should we be taking care of this? If so, please either insert kewisch@moco or mozilla@kewis.ch as the moderator.
(Reporter)

Comment 2

5 years ago
The mailing list has always had a moderator (me!). The way Mozilla moderated newsgroups are set up is that the list address is the moderator address. That means newsgroup posts go through mailman before making it to the newsgroup. If you want, I can add you as a moderator.
(Reporter)

Comment 3

5 years ago
Gerv, does this need your go-ahead? If not, who should this be assigned to?
It doesn't need my go-ahead; server-ops are the people.

Gerv
Assignee: gerv → server-ops
(Assignee)

Updated

5 years ago
Assignee: server-ops → mburns
(Assignee)

Updated

5 years ago
Whiteboard: [waiting for Giganews]
(Reporter)

Comment 5

5 years ago
A couple of days ago, I got two moderator requests for posts made by a Giganews employee. I replied to him to confirm the tests. Since then, I've received a couple of moderator requests from people posting via the newsgroup.

Is this fixed and Giganews just forgot to tell us?
(Reporter)

Comment 6

5 years ago
It looks like:
1) Giganews set this up last week, but Google hasn't. (Posts via Google are still no being sent to me for moderation, but nntp posts are.)
2) approved newsgroup moderation request are not posted to the newsgroup.

To prevent people from thinking their posts are going into a black hole, I've set https://lists.mozilla.org/admin/support-calendar/?VARHELP=gateway/news_moderation to "Open list, moderated group", which is where it is supposed to be set when this bug is fixed.

That appears to have fixed #2.
(Reporter)

Comment 7

5 years ago
I sent a test message via Google:
* After clicking [Post message], I was told my message would appear momentarily (nothing about waiting for moderator approval).
* The message did not appear (I waited 15 minutes).
* I got an email notification right away from mailman that the message was waiting for moderator approval.

Once I approved the message, it appeared on Google with mailman headers <http://groups.google.com/group/mozilla.support.calendar/msg/648cd4abc0125f94?dmode=source>.
(Assignee)

Updated

5 years ago
Depends on: 716007
cilias: is this working now? If you think it isn't and haven't tested in a while, please retest, as Google have now said they think everything is as we have requested.

Gerv
(Reporter)

Comment 9

5 years ago
I thought it was fixed, because I had seen messages posted via Google. The latest one is from Aug 23. (There are a couple others, but they were also CCed to the list)

So I decided to test it myself. For the past couple of days I haven't been able to post via Google Groups. Today I created a new GG account, joined the group, and tried to post, but none of those posts have shown up, and none of them are in the moderator que (although I have handled some spam messages in the moderator que since then).

Google groups is now giving me a message, "Your message is taking a long time to process. If it does not show up shortly, please try again."

So it looks like this used to be fixed, but it isn't now.
Chris: so, to be clear, you are having problems posting to mozilla.support.calendar via Google Groups? And the problem is that posts are not showing up in the group, and you are instead getting the error listed in comment #9?

Brad: is this something you could look into?

Thanks,

Gerv
Oops. De-CCing Brad, and CCing Brandon!

Gerv
(Reporter)

Comment 12

5 years ago
When I post I don't get an error. Here's a screencast: <http://ilias.ca/screencasts/support-calendar-gg.webm>.

After that, if I leave it alone for a while (maybe a minute), I'll get the message in comment 9. Here's a screenshot: <http://ilias.ca/screenshots/support-calendar-gg.png>.

Comment 13

5 years ago
We have the wrong moderator address for mozilla.* in the new system, I'm making the change now, hopefully it'll be in production tomorrow.
(Reporter)

Comment 14

5 years ago
I just did a test, and it works now.
Awesome. Thanks, Brandon :-)

Gerv
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.