Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 735787 - Make moderated
: Make moderated
[waiting for Giganews]
Classification: Other
Component: Discussion Forums (show other bugs)
: other
: All All
: -- normal (vote)
: ---
Assigned To: Michael Burns [:mburns]
: Dave Miller [:justdave] (
Depends on: 716007
  Show dependency treegraph
Reported: 2012-03-14 11:33 PDT by Chris Ilias [:cilias]
Modified: 2012-09-24 05:53 PDT (History)
6 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---


Description Chris Ilias [:cilias] 2012-03-14 11:33:44 PDT
In bug 635078, the new support newsgroup configuration was applied to, and we tested the spam filter in bug 663318. I think we're now ready to apply that configuration to rest of the support newsgroups. is a low-traffic group we can apply this to before applying it to the firefox and thunderbird support newsgroups.

I just need the group set as moderated, the same way other moderated Mozilla newsgroups are configured. The rest I can do via the list admin UI.
Comment 1 Philipp Kewisch [:Fallen] 2012-03-15 07:15:30 PDT
Who will be doing the moderation? Should we be taking care of this? If so, please either insert kewisch@moco or as the moderator.
Comment 2 Chris Ilias [:cilias] 2012-03-15 12:20:28 PDT
The mailing list has always had a moderator (me!). The way Mozilla moderated newsgroups are set up is that the list address is the moderator address. That means newsgroup posts go through mailman before making it to the newsgroup. If you want, I can add you as a moderator.
Comment 3 Chris Ilias [:cilias] 2012-04-04 12:59:48 PDT
Gerv, does this need your go-ahead? If not, who should this be assigned to?
Comment 4 Gervase Markham [:gerv] 2012-04-05 02:14:52 PDT
It doesn't need my go-ahead; server-ops are the people.

Comment 5 Chris Ilias [:cilias] 2012-04-11 13:57:44 PDT
A couple of days ago, I got two moderator requests for posts made by a Giganews employee. I replied to him to confirm the tests. Since then, I've received a couple of moderator requests from people posting via the newsgroup.

Is this fixed and Giganews just forgot to tell us?
Comment 6 Chris Ilias [:cilias] 2012-04-17 15:12:04 PDT
It looks like:
1) Giganews set this up last week, but Google hasn't. (Posts via Google are still no being sent to me for moderation, but nntp posts are.)
2) approved newsgroup moderation request are not posted to the newsgroup.

To prevent people from thinking their posts are going into a black hole, I've set to "Open list, moderated group", which is where it is supposed to be set when this bug is fixed.

That appears to have fixed #2.
Comment 7 Chris Ilias [:cilias] 2012-04-23 16:38:32 PDT
I sent a test message via Google:
* After clicking [Post message], I was told my message would appear momentarily (nothing about waiting for moderator approval).
* The message did not appear (I waited 15 minutes).
* I got an email notification right away from mailman that the message was waiting for moderator approval.

Once I approved the message, it appeared on Google with mailman headers <>.
Comment 8 Gervase Markham [:gerv] 2012-09-17 03:34:11 PDT
cilias: is this working now? If you think it isn't and haven't tested in a while, please retest, as Google have now said they think everything is as we have requested.

Comment 9 Chris Ilias [:cilias] 2012-09-18 18:15:13 PDT
I thought it was fixed, because I had seen messages posted via Google. The latest one is from Aug 23. (There are a couple others, but they were also CCed to the list)

So I decided to test it myself. For the past couple of days I haven't been able to post via Google Groups. Today I created a new GG account, joined the group, and tried to post, but none of those posts have shown up, and none of them are in the moderator que (although I have handled some spam messages in the moderator que since then).

Google groups is now giving me a message, "Your message is taking a long time to process. If it does not show up shortly, please try again."

So it looks like this used to be fixed, but it isn't now.
Comment 10 Gervase Markham [:gerv] 2012-09-19 03:21:57 PDT
Chris: so, to be clear, you are having problems posting to via Google Groups? And the problem is that posts are not showing up in the group, and you are instead getting the error listed in comment #9?

Brad: is this something you could look into?


Comment 11 Gervase Markham [:gerv] 2012-09-19 03:34:22 PDT
Oops. De-CCing Brad, and CCing Brandon!

Comment 12 Chris Ilias [:cilias] 2012-09-19 14:10:07 PDT
When I post I don't get an error. Here's a screencast: <>.

After that, if I leave it alone for a while (maybe a minute), I'll get the message in comment 9. Here's a screenshot: <>.
Comment 13 Brandon Long 2012-09-19 16:35:36 PDT
We have the wrong moderator address for mozilla.* in the new system, I'm making the change now, hopefully it'll be in production tomorrow.
Comment 14 Chris Ilias [:cilias] 2012-09-20 13:34:29 PDT
I just did a test, and it works now.
Comment 15 Gervase Markham [:gerv] 2012-09-24 05:53:26 PDT
Awesome. Thanks, Brandon :-)


Note You need to log in before you can comment on or make changes to this bug.