Last Comment Bug 735829 - Report PDB name in chrome hang reports
: Report PDB name in chrome hang reports
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Vladan Djeric (:vladan)
:
:
Mentors:
Depends on: 712109
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 13:12 PDT by Vladan Djeric (:vladan)
Modified: 2012-03-27 05:16 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Report PDB Name, v1 (7.13 KB, patch)
2012-03-16 12:15 PDT, Vladan Djeric (:vladan)
ehsan: review+
Details | Diff | Splinter Review
Very minor fix: add quotes around PDB name string (1.02 KB, patch)
2012-03-26 19:04 PDT, Vladan Djeric (:vladan)
vladan.bugzilla: checkin+
Details | Diff | Splinter Review

Description Vladan Djeric (:vladan) 2012-03-14 13:12:38 PDT
Currently, chrome hang reports report a variety of info about shared libraries loaded in memory including the shared library name, address information, and PDB Signature + PDB Age. This information is used for server-side symbolication of hang stacks. However, symbol files are stored on the server under their PDB name and not the shared library name, e.g. the XUL library symbols are stored in a directory named xul.pdb instead of xul.dll.

As it turns out, the shared library names do not always neatly map to their PDB filenames, e.g. on my machine c:\Windows\SysWOW64\ntdll.dll has a PDB named wntdll.pdb.

Therefore, chrome hang reports should also report the corresponding PDB name for shared libraries. The PDB name can be obtained from the library image, the same way as PDB signatures and PDB ages.
Comment 1 Vladan Djeric (:vladan) 2012-03-16 12:15:51 PDT
Created attachment 606671 [details] [diff] [review]
Report PDB Name, v1
Comment 2 :Ehsan Akhgari 2012-03-16 15:19:42 PDT
Comment on attachment 606671 [details] [diff] [review]
Report PDB Name, v1

Review of attachment 606671 [details] [diff] [review]:
-----------------------------------------------------------------

::: tools/profiler/shared-libraries-win32.cc
@@ +50,5 @@
>  {
>    uint32_t signature;
>    GUID pdbSignature;
>    uint32_t pdbAge;
> +  char pdbFileName[1];

Make it a char* and take out the cast below.
Comment 3 Mounir Lamouri (:mounir) 2012-03-20 03:50:28 PDT
https://hg.mozilla.org/mozilla-central/rev/102524521984
Comment 4 Vladan Djeric (:vladan) 2012-03-26 19:04:53 PDT
Created attachment 609581 [details] [diff] [review]
Very minor fix: add quotes around PDB name string

Fixing small bug introduced in the first patch
Comment 6 Ed Morley [:emorley] 2012-03-27 05:16:42 PDT
https://hg.mozilla.org/mozilla-central/rev/d69e6105b5b1

Note You need to log in before you can comment on or make changes to this bug.