[New Tab Page] Dropping blocked links onto the grid again should unblock them

RESOLVED FIXED in Firefox 13

Status

()

Firefox
General
RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: Optimizer, Assigned: ttaubert)

Tracking

13 Branch
Firefox 14
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox13 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
When you add a site manually to the New Tab Page, you cannot remove it by clicking on the cross button on upper right corner unless you unpin it.
And if you unpin it after clicking on the cross atleast once, then it automatically gets removed on unpinning.
(Reporter)

Comment 1

5 years ago
PS: This behavior is visible only after the New layout for NTP landed.
(Reporter)

Updated

5 years ago
Blocks: 729878, 455553
This happens randomly.
(Reporter)

Comment 3

5 years ago
The STR are very complex for this bug, 
1) All the other tabs should be pinned (either manually added or pinning the already existing thumbnails)
2) This only happens to the thumbnails added manually
3) This does not start happening untill all the tiles are filled and pinned.
4) But once the above condition is satisfied, this will happen untill you close the page, even if you remove the already existing sites.

Still there might be some other STR also. This is random at times.
(Assignee)

Updated

5 years ago
Assignee: nobody → ttaubert
Summary: Manually pinned Sites on NTP does not get removed on clicking the cross button. → Dropping blocked links onto the grid again should unblock them
(Assignee)

Updated

5 years ago
Summary: Dropping blocked links onto the grid again should unblock them → [New Tab Page] Dropping blocked links onto the grid again should unblock them
(Assignee)

Comment 4

5 years ago
Created attachment 606141 [details] [diff] [review]
patch v1

Unblocks a link before pinning it on the grid when accepting an external drop.
Attachment #606141 - Flags: review?(dietrich)
Attachment #606141 - Flags: review?(dietrich) → review+
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/34a7a331811f
Status: NEW → ASSIGNED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 14
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/mozilla-central/rev/34a7a331811f
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
(Assignee)

Comment 7

5 years ago
Comment on attachment 606141 [details] [diff] [review]
patch v1

[Approval Request Comment]
Regression caused by (bug #): new newtab layout
User impact if declined: weird behavior, removing a site not working
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): small patch with test
String changes made by this patch: none
Attachment #606141 - Flags: approval-mozilla-aurora?

Comment 8

5 years ago
Comment on attachment 606141 [details] [diff] [review]
patch v1

[Triage Comment]
Low risk patch in support of correctness in a new feature. Approved for Aurora 13.
Attachment #606141 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/4b7327c0fd00
status-firefox13: --- → fixed
Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20120424 Firefox/13.0a2

Verified on Mac OS 10.6, Ubuntu 11.10 and Windows 7.

1. Manually add a site to the new tab page.
2. Close the new tab page.
3. Open the new tab page.
4. remove the site added in step 1. 

The site can now be removed.
status-firefox13: fixed → verified
(Assignee)

Updated

5 years ago
Depends on: 767693

Comment 11

a year ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=ca13a15a1e54

Comment 12

a year ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=c5e1ba6d6ab9
You need to log in before you can comment on or make changes to this bug.