icons of twitter accounts should be shown in each tweet

RESOLVED FIXED in Thunderbird 14.0

Status

Thunderbird
Instant Messaging
--
enhancement
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: masayuki, Assigned: andreasn)

Tracking

Trunk
Thunderbird 14.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

The icons of twitter accounts should be shown in each tweet.
OS: Windows 7 → All
Hardware: x86_64 → All
(Assignee)

Comment 1

5 years ago
Do you mean the avatars?
I meant "Picture" in the editing profile page of Twitter.
(Assignee)

Comment 3

5 years ago
Agreed, lets do it!
Assigning to me.
Assignee: nobody → nisses.mail
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

5 years ago
Created attachment 606542 [details] [diff] [review]
first patch

Still some small issues to iron out, but mostly there.
(Assignee)

Comment 5

5 years ago
Created attachment 606556 [details] [diff] [review]
patch (v2)

This makes sure that it works even if you don't have a avatar set.
Attachment #606542 - Attachment is obsolete: true
(Assignee)

Comment 6

5 years ago
Created attachment 607118 [details] [diff] [review]
patch (v3)

Also makes sure to give avatars to incoming messages without avatar icon set and gives the photo some border-radius.
Attachment #606556 - Attachment is obsolete: true
Attachment #607118 - Flags: ui-review?(bwinton)
Attachment #607118 - Flags: review?(mconley)
Comment on attachment 607118 [details] [diff] [review]
patch (v3)

Review of attachment 607118 [details] [diff] [review]:
-----------------------------------------------------------------

Ack - I had a review for this, but I guess it never got published!  :/

The code looks good, except for the nit I found. r=me.

::: mail/components/im/messages/main.css
@@ +179,5 @@
>    background: url('Bitmaps/minus-hover.png') no-repeat left top;
>  }
>  
> +.usericon {
> +  position: absolute;'

There's a trailing apostrophe here that needs to go.
Attachment #607118 - Flags: review?(mconley) → review+
(Assignee)

Comment 8

5 years ago
Created attachment 609291 [details] [diff] [review]
patch (v3)

Apostrophe typo removed, carrying over r+ from previous patch
Attachment #607118 - Attachment is obsolete: true
Attachment #607118 - Flags: ui-review?(bwinton)
Attachment #609291 - Flags: ui-review?(bwinton)
Attachment #609291 - Flags: review+
Comment on attachment 609291 [details] [diff] [review]
patch (v3)

I'm going to say ui-r=me, based on the Mac behaviour.  I'm trying to see how it looks on Windows, but it's going really slowly, and it would be nice if it could get checked in while we wait for my VM to build…

Thanks,
Blake.
Attachment #609291 - Flags: ui-review?(bwinton) → ui-review+
Pushed to comm-central as http://hg.mozilla.org/comm-central/rev/7105b9c97546

Did we want this for comm-aurora too?
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Target Milestone: --- → Thunderbird 14.0

Updated

5 years ago
Attachment #609291 - Flags: approval-comm-aurora?
Attachment #609291 - Flags: approval-comm-aurora? → approval-comm-aurora+
This caused bug 741856.
Depends on: 741856
Should we not push this to aurora until bug 741856 is fixed then?
(In reply to Mark Banner (:standard8) from comment #12)
> Should we not push this to aurora until bug 741856 is fixed then?

That's what I would do, but others may disagree.
Comment on attachment 609291 [details] [diff] [review]
patch (v3)

Ok, backing this down to a request, as we need the other bug fixing first.
Attachment #609291 - Flags: approval-comm-aurora+ → approval-comm-aurora?
Depends on: 742235
Comment on attachment 609291 [details] [diff] [review]
patch (v3)

We are disabling IM for Tb13 so I don't think we want this on aurora anymore.
Attachment #609291 - Flags: approval-comm-aurora?
(In reply to Florian Quèze from comment #15)
> Comment on attachment 609291 [details] [diff] [review]
> patch (v3)
> 
> We are disabling IM for Tb13 so I don't think we want this on aurora anymore.

Some clarification:
- disabling IM for Tb13 beta is happening in bug 748323
- bug 741856 (the reason why we haven't landed this on aurora earlier) has been resolved as WORKSFORME because bug 742235 got fixed and improved this significantly.
You need to log in before you can comment on or make changes to this bug.