Last Comment Bug 736032 - (LM-Math) Support for Latin Modern Math in MathML
(LM-Math)
: Support for Latin Modern Math in MathML
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: MathML (show other bugs)
: Trunk
: All All
: P5 normal with 2 votes (vote)
: mozilla31
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.gust.org.pl/projects/e-fou...
Depends on: 407059 947650
Blocks: 947654
  Show dependency treegraph
 
Reported: 2012-03-15 03:42 PDT by Frédéric Wang (:fredw)
Modified: 2014-04-25 00:47 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Frédéric Wang (:fredw) 2012-03-15 03:42:35 PDT
The Latin Modern Math (LM Math) fonts complete the modernization of the Computer Modern family of typefaces designed and programmed by Donald E. Knuth.

That modernization started with the provision of the Latin Modern (LM) family of text fonts in the modern OpenType format and with a far richer set of diacritics and other glyphs making it suitable for typesetting of most Latin scripts.

However, the modernization was incomplete without the math fonts of the Comupter Modern family which were one of the main reasons for the widespread use of the Computer Modern fonts, most notably to typeset papers containing mathematical formulas.

LM and LM Math taken together may now be regarded as a full descendant of Computer Modern.

The Latin Modern Math fonts are licensed under the GUST Font License (GFL), which is a free license, legally equivalent to the LaTeX Project Public License (LPPL), version 1.3c or later.
Comment 1 Frédéric Wang (:fredw) 2013-04-10 05:16:44 PDT
Related OpenType Math font of the GUST projects:
http://www.gust.org.pl/projects/e-foundry/math/index_html

"At the moment, GUST e-Foundry has released Latin Modern Math, TG Pagella Math and TG Termes Math. The two remaining TeX Gyre OTF math fonts are expected to be released in 2013."
Comment 2 Frédéric Wang (:fredw) 2014-04-25 00:47:36 PDT
I'm closing all these font-specific meta bug since the main work has been done in bug 407059 and bug 947650. Remaining issues will be handled on the OpenType MATH bugs.

Once bug 1000879 is merged, one will be able to verify the initial OpenType MATH support with the MathML torture test:
https://developer.mozilla.org/en-US/docs/Mozilla/MathML_Project/MathML_Torture_Test

Note You need to log in before you can comment on or make changes to this bug.