All large icons on standard toolbar display as small

VERIFIED INVALID

Status

()

Firefox
Theme
VERIFIED INVALID
6 years ago
3 years ago

People

(Reporter: realRaven, Unassigned)

Tracking

11 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 606171 [details]
wrong-icon-sizes.png

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

Start up Fx with default theme, Toolbars are set to "normal" size icons, but show up as small.


Actual results:

All icons on the main toolbar are displayed 16*16pixels even those of addons which previously showed in normal size (e.g. QuickPasswords, Zombie Keys, AdBloxk Plus, Empty Cache)


Expected results:

Icons should show in 24*24 like in previous builds, unless "Use Small Icons" is selected. The workaround is to go to customize toolbar toggle "Use Small Icons" on, click Apply, uncheck "Use Small Icon", click Ok again => icons return to normal size. Opening a new window will also display icons in the wrong size (too small). I was wondering if I should reopen Bug 171731 but it seems quite old.
(Reporter)

Updated

6 years ago
Summary: icon size too small → All large icons on standard toolbar display as small
#WONTFIX

with the new UI "Australis" this icons are no more used...
so we should close this.
(In reply to Stefan Weiss [:sir_none] from comment #1)
> #WONTFIX
> 
> with the new UI "Australis" this icons are no more used...
> so we should close this.

Well, some icons are still used, even in Australis. Think the bookmark and download ones, and those of some add-ons (I have only a couple installed, but I can see Adblock icon in the toolbar).
What is no longer there, I think, is the ability to choose the size of the icons. (Or at least I haven't found it).

In this case, I'd ask the reporter if he's still experiencing the problem with a recent version of Firefox.

Axel: are you still experiencing this problem? I wasn't able to reproduce it, and I was curious to know - before eventually close this bug - if you can test a more recent version of Firefox and check if the bug happens.


Thanks,
Francesca
Flags: needinfo?(axelg)
(Reporter)

Comment 3

3 years ago
(In reply to Francesca Ciceri [:madamezou] from comment #2)
> (In reply to Stefan Weiss [:sir_none] from comment #1)
> > #WONTFIX
> > 
> > with the new UI "Australis" this icons are no more used...
> > so we should close this.
> 
> Well, some icons are still used, even in Australis. Think the bookmark and
> download ones, and those of some add-ons (I have only a couple installed,
> but I can see Adblock icon in the toolbar).
> What is no longer there, I think, is the ability to choose the size of the
> icons. (Or at least I haven't found it).
> 
> In this case, I'd ask the reporter if he's still experiencing the problem
> with a recent version of Firefox.
> 
> Axel: are you still experiencing this problem? I wasn't able to reproduce
> it, and I was curious to know - before eventually close this bug - if you
> can test a more recent version of Firefox and check if the bug happens.

While there is not [x] small icons UI, with the default Firefox theme I can use DOM inspector to toggle the "iconsize" attribute to "large". The good thing is that (most) Addon Icons display as expected. The built in icons remain the same size but add padding - I wouldn't necessarily say this is a bug, just a choice of the theme designer. I think it is important that iconsize="large" remains supported (even though there is no UI to set it directly) for people who have eye-sight problems.

I would agree to WONTFIX the bug as well.
Flags: needinfo?(axelg)
Good point Axel. I looked around for Addons and there are some to make the buttons in the toolbar bigger. For example, https://addons.mozilla.org/en-US/firefox/addon/big-buttons/.  

I'll ask in the #accessibility irc channel if we still support iconsize="large".
Actually... it looks like this still works as expected since you can change iconsize to large and the icons change.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

3 years ago
(In reply to Liz Henry :lizzard from comment #5)
> Actually... it looks like this still works as expected since you can change
> iconsize to large and the icons change.

nice one. Although personally I would find it better if the icons of the default theme would be upscaled to 24px*24px rather than just adding padding. I haven't got the youngest eyes either anymore :(

Comment 7

3 years ago
Gijs, can you comment?
Component: Untriaged → Theme
Flags: needinfo?(gijskruitbosch+bugs)

Comment 8

3 years ago
We don't support different iconsizes on the main toolbar anymore, so this is no longer valid.
Status: RESOLVED → VERIFIED
Flags: needinfo?(gijskruitbosch+bugs)
You need to log in before you can comment on or make changes to this bug.