viewsource linkification broken in FF11

RESOLVED DUPLICATE of bug 617789

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 617789
6 years ago
6 years ago

People

(Reporter: mtness, Unassigned)

Tracking

11 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
linkification in FF11 doesn't work witrh relative links anymore.

plz fix ASAP!

Comment 1

6 years ago
Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile

Please provide a public URL or reduced test case that exhibits this issue.
(Reporter)

Comment 2

6 years ago
Hi Tim!

Yes, the issue occurs in Safe Mode and with a new profile, too.

Valid testcases are found here:

http://typo3.org/extensions/repository/
Ctrl+U -> click on any link or script resource

or here:
http://modx.com/download/
Ctrl+U -> click on any relative link

basically it happens on all relative links which aren't prepended with a slash.
This used to work since the feature was introduced with FF3.5.

Comment 3

6 years ago
WFM - Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20120316 Firefox/14.0a1 ID:20120316031151

Can you attach a screenshot of what you see? Are the links not underlined?

Will try an install of Firefox 11 if I get a chance, but if it is broken on 11 it has since been fixed
(Reporter)

Comment 4

6 years ago
The links work, but they do not work with base href anymore.

For example, if we are on the page http://modx.com/download/, and click on any relative link on the page, i.e. "partners/solution/" [which should result in modx.com/partners/solution/], click on the link produces the following URL: http://modx.com/download/partners/solution/

Comment 5

6 years ago
I see now. Found a duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 617789
You need to log in before you can comment on or make changes to this bug.