Ignore "devtools.inspector.enabled" preference

RESOLVED DUPLICATE of bug 736465

Status

P2
normal
RESOLVED DUPLICATE of bug 736465
7 years ago
4 months ago

People

(Reporter: paul, Unassigned)

Tracking

Trunk
Firefox 16
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Some users use "devtools.inspector.enabled" to disable the "inspect" menu entry in the context menu. Once we will get the a specific pref for disabling this entry, we should consider not disabling the inspector if "devtools.inspector.enabled" is false.

Comment 1

7 years ago
That pref was originally intended as a kill switch during development of the inspector feature.  Now that we've shipped, disabling that pref gets almost no testing, so this suggestion makes sense.

Comment 2

7 years ago
What's the transition plan for users who have already flipped the pref? Would they automatically have the new UI pref defaulted to off (assuming, for some strange reason, that it defaulted to on), or would they have to hunt for the new pref to get their old behaviour back?
(Reporter)

Comment 3

7 years ago
(In reply to Chris Cunningham from comment #2)
> What's the transition plan for users who have already flipped the pref?
> Would they automatically have the new UI pref defaulted to off (assuming,
> for some strange reason, that it defaulted to on), or would they have to
> hunt for the new pref to get their old behaviour back?

I guess we can assume that people who preffed off the inspector did it because of the menuitem.
So we could just have some transition code that would use the initial pref as a default value.
I would suggest:

devtools.inspector.contextMenu.enabled for your preference.

For users with explicitly-disabled devtools.inspector.enabled prefs, we could automatically set .contextMenu to false.

make sense?

Comment 5

7 years ago
Let's try to get this for 16.
Priority: -- → P2
Target Milestone: --- → Firefox 16
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 736465

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.