Last Comment Bug 736486 - Next unread message over multiple accounts with a IM account set up doesn't work
: Next unread message over multiple accounts with a IM account set up doesn't work
Status: VERIFIED FIXED
: regression
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 14.0
Assigned To: Florian Quèze [:florian] [:flo]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 09:07 PDT by Richard Marti (:Paenglab)
Modified: 2012-04-02 04:07 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Patch (959 bytes, patch)
2012-03-16 15:35 PDT, Florian Quèze [:florian] [:flo]
mozilla: review+
mozilla: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Richard Marti (:Paenglab) 2012-03-16 09:07:54 PDT
When I have set up for example a IRC account and then I am reading the new messages jumping to the next unread message in a news account doesn't work.

The error console shows:
Error: An error occurred executing the cmd_nextUnreadMsg command: TypeError: rootFolders[i] is null
Source file: chrome://global/content/globalOverlay.js
Line: 100

I have multiple mail accounts, then Feeds and then two News accounts. Without a IM account I can jump through all new messages.

With a IM account I can jump between all mail accounts and Feeds but then it stops and I have to go manually to the news account to read the new messages. Also between the news accounts the automatic jump doesn't work (and also from News back to mail).

When I remove the IM account everything is working again.

Can it be it's because the IM accounts are between Mail/Feed and News placed in Account manager?
Comment 1 Richard Marti (:Paenglab) 2012-03-16 09:10:32 PDT
I'm not sure where I should place this bug.

Because the IM component is regressing this function, I'm adding Florian to this bug.
Comment 2 Florian Quèze [:florian] [:flo] 2012-03-16 15:35:21 PDT
Created attachment 606764 [details] [diff] [review]
Patch

Yet another piece of code expecting all nsIMsgAccount instances to have folders...

(By the way, while mxr'ing around to understand this bug, I queried "41133" and found another function that needs to be fixed: FillIdentityList in http://mxr.mozilla.org/comm-central/source/mail/components/compose/content/MsgComposeCommands.js#3223 I'll file a separate bug on it once I've understood what this breaks exactly; I suspect it's the initialization of the Compose window for identities associated with email accounts created after an IM account.)
Comment 3 David :Bienvenu 2012-03-16 16:48:26 PDT
Comment on attachment 606764 [details] [diff] [review]
Patch

I wonder if it would possible to tweak the mozmill tests to define an im account in the default profile and see if any of the tests break in interesting ways.
Comment 4 Florian Quèze [:florian] [:flo] 2012-03-23 04:57:41 PDT
http://hg.mozilla.org/comm-central/rev/5c89e26d606f
Comment 5 Florian Quèze [:florian] [:flo] 2012-03-23 04:59:23 PDT
(In reply to Florian Quèze from comment #2)

> (By the way, while mxr'ing around to understand this bug, I queried "41133"
> and found another function that needs to be fixed: FillIdentityList in
> http://mxr.mozilla.org/comm-central/source/mail/components/compose/content/
> MsgComposeCommands.js#3223 I'll file a separate bug on it once I've
> understood what this breaks exactly; I suspect it's the initialization of
> the Compose window for identities associated with email accounts created
> after an IM account.)

After looking at this again, I don't think a fix is actually needed. The function iterates over account.identities for each account. For IM accounts I think this array will just be empty and the function will move on.
Comment 6 Florian Quèze [:florian] [:flo] 2012-03-23 11:15:11 PDT
(In reply to David :Bienvenu from comment #3)
> I wonder if it would possible to tweak the mozmill tests to define an im
> account in the default profile and see if any of the tests break in
> interesting ways.

Filed bug 738719 on this.
Comment 7 Richard Marti (:Paenglab) 2012-03-24 13:43:42 PDT
The jumping over the accounts works now again. Thanks for fixing this.
Comment 8 Florian Quèze [:florian] [:flo] 2012-03-30 06:03:07 PDT
Comment on attachment 606764 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug 714733): IM in Tb.
User impact if declined: some brokenness of the email UX when IM accounts exist.
Comment 9 Florian Quèze [:florian] [:flo] 2012-04-02 04:07:13 PDT
http://hg.mozilla.org/releases/comm-aurora/rev/3a17c060e6d9

Note You need to log in before you can comment on or make changes to this bug.