Event disappears when Edit Event dialog is opened then saved

RESOLVED DUPLICATE of bug 735619

Status

RESOLVED DUPLICATE of bug 735619
7 years ago
6 years ago

People

(Reporter: patd, Unassigned)

Tracking

Lightning 1.2

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

Calendar is set to Month view. Double-clicked an event that was already in the calendar. The Edit Event window opened. I did not make any changes to the event. Closed Edit Event dialog using the Save and Close button. Got the Save Event dialog - "Event has not been saved. Do you want to save the Event?". Clicked "Save". (BTW- Prior to this recent upgrade, I do not think that Save Event dialog came up if I did not make any changes.)


Actual results:

Immediately after I close and save the event still appears in the Calendar. But when I go to my Inbox tab then return to the Calendar, the event has disappeared. This happens for events set in the past as well as events set in the future. It also happens if I click the red X instead of the Save and Close button.

I am using an Intel-based Mac with op sys 10.7.3, but this is happens on other computers in our office, including Windows computers. Because it is an Add-On to Thunderbird (10.0.2), the Calendar appears as a tab in Thunderbird. 


Expected results:

The events should not disappear!

Comment 1

7 years ago
Do you have more than one Google calendar? I'm wondering whether this might be related to Bug 735619, where an event moves to another calendar upon editing it.

Also, concerning your mention of the Save Event dialog; I believe you are correct and that this is a recent implementation in the calendar code. It is unclear (to me, at least), though, whether this actually triggers any aberrant behavior.
(Reporter)

Comment 2

7 years ago
Lewis, some of us have additional calendars and some of us do not. I do not have an additional calendar on my work (Mac) computer (where I am currently seeing the problem) but I do have one on my home (Win) computer, which also has the problem.

I did find out that after clicking the Save and Close button (Edit Event dialog) the Save Event dialog does not always appear. If it does appear and I click Do Not Save, the event does NOT disappear. If it does appear and I click Save, the event does disappear. Also, if the Save Event dialog does not appear, the event always disappears.
(Reporter)

Comment 3

7 years ago
For those here who have a second (Home) Google calendar, the event does not appear on the second calendar, so I don't think it moves but instead is just gone.

This bug is new since we updated about a month ago. Just haven't had time to report it.

Comment 4

7 years ago
I have a similar issue which I suspect has the same cause. When I edit an event from Thunderbird/Lightning, the event is usually deleted after I save and close. This usually happens if I change the date and/or time of the event, but it may also happen if I add a comment (which happened just now).

I'm in a bit of a hurry and wanted to post the issue before I forgot, but I'll try and reproduce later and post exact results and behaviour.

Comment 5

6 years ago
Reproduced just now. Here's what I did:
- Create event through Thunderbird-Lightning on a Google calendar.
- Check Google calendar web interface for the new event (should appear almost immediately after creation).
- Once the event appears on the web interface, open the event edit dialogue in Thunderbird again and change the date (in my case the original event was for the next day and I moved it one week forward).
- Save and close event.

What happens:
- The event is moved to the new date in Thunderbird-Lightning.
- On the calendar web interface the event disappears.
- If you force synchronise the Thunderbird calendars, the event disappears from Thunderbird as well.

The same happens if you change the time without changing the date.
I believe this is the same root issue as Bug 735619, which is fixed in Lightning 1.4b3. 

@patd@extendsim.com, Achilleas: is it possible for you to test this with Thunderbird 12.0b4 + Lightning 1.4b3?

https://www.mozilla.org/en-US/thunderbird/all-beta.html
https://addons.mozilla.org/en-US/thunderbird/addon/lightning/#beta-channel
Depends on: 735619

Comment 7

6 years ago
I'll give the betas a try when I get the chance. Thanks for the info.
I'll post accordingly.
(In reply to Matthew Mecca [:mmecca] from comment #6)
> I believe this is the same root issue as Bug 735619, which is fixed in
> Lightning 1.4b3.

Yeah, this bug has symptoms similar to those of bug 728643 which is a dupe of bug 735619.
Achilleas: if Tb 12.0b4 + L 1.4b3 don't show the bug then it can be RESOLVED DUPLICATE.
(Reporter)

Comment 9

6 years ago
Sorry, I can't use the beta version of Thunderbird as this is on work computers. "Lightening 1.3 is the latest stable release built for Thunderbird 11".

Comment 10

6 years ago
I'm using Arch Linux and it seems some of the shared libraries used by Thunderbird have different names. Downloading the Mozilla package doesn't work "out of the box" and Tb12 isn't in the testing repository yet.

Comment 11

6 years ago
I can confirm that my issue (can't say for patd) is a duplicate of bug 735619. I only just now realised that the events appear to be removed because I have the default calendar disabled.

Comment 12

6 years ago
I believe I have the same issue using TB 11 and Lightning 1.3. accessing a google calendar through the private link.  I too, cannot install the newer version as this is in a production environment.

I can confirm that if I open an existing event, even if I make no changes, but say save it, the event disappears.  I have also tried in week view and the same thing happens. If I am making quick change soon after the initial entry was saved, the dialog pops up asking if I want to change it on the server, I always say change it on the server, and it still disappears.

I don't know if it is related or not, but I also cannot change a category from none to another one, if I am doing that as an edit, instead of when the event is first changed.  

I feel this is a critical bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 735619
You need to log in before you can comment on or make changes to this bug.