replace redundant license notices in '.jar' with single notice

VERIFIED DUPLICATE of bug 68686

Status

SeaMonkey
Build Config
P5
normal
VERIFIED DUPLICATE of bug 68686
18 years ago
14 years ago

People

(Reporter: John Morrison, Assigned: cls)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Filing as a separate bug, to avoid mixing this issue in with bug 73256.
I'm not whole-heartedly endorsing this idea, but it is a relatively 
simple way to trim ~250KB of download size.

   $src =~ s!(/\*.*?contents of this file.*?\*/)!!s; # :-]

------- Additional Comments From John Morrison 2001-03-26 18:01 -------

(Only commenting on the _download_ size issue ... we can shrink comm.jar by 
88KB just by stripping out the MPL from the 223 files in comm.jar that have it
(yeah, I actually measured this :-). If done for all jars, this may be ~250KB,
which is a minute of download time for a dialup user. The build folks may wish
to do this although it probably needs a separate bug. (I'm assuming that a 
single license in the top level of a single jar file would be enough to satisfy 
legal requirement)).



------- Additional Comments From Frank Hecker 2001-03-26 21:52 -------

I personally am OK with the idea of stripping out the MPL verbiage in order to 
create the jar file. (I think this came up before in some context -- maybe 
with XUL files?) I see this as no different than stripping out 
license-related comments in compiled C/C++ -- the jar file as distributed (with 
license notices stripped out or compressed) is essentially in "executable" form 
compared to the original source files. I think leaving a single license notice 
in the jar file (for all files) is OK -- presuming (an important point!) that 
all the files in the jar file are in fact under the same license.



------- Additional Comments From timeless@mac.com 2001-03-26 22:26 -------

we should probably implement about:npl, about:mpl, and about:license first -- i 
don't remember the bug id.



------- Additional Comments From mitchell@mozilla.org 2001-03-27 11:57 -------

First, I assume we're talking about the notice ("This file is governed by the
terms of the MPL ...") and not the license itself.  There's no question about
the latter, the license itself does not belong here.

I'm generally unhappy with the idea of files that don't have any license 
notice, and we can't pull these out for source releases.  But I agree with 
Frank that it can be done for the executables.  And timeless is right, we 
should also make sure the the notice about the MPL is visible and easy to find.



------- Additional Comments From Jon Granrose 2001-03-27 13:07 -------

we should file a separate bug on the license removal to avoid confusing it with
JS crunching.
(Assignee)

Updated

18 years ago
Priority: -- → P5
Target Milestone: --- → Future
*** Bug 68686 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 68686 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
verified dupe; although the dupe is more general in clean up purpose and may not
be fixed.  

Please reopen this bug if you really want to replace redundant license notices
in '.jar' with a single notice
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.