Closed Bug 736611 Opened 9 years ago Closed 9 years ago

Browser is not not focused when opening links from external applications

Categories

(SeaMonkey :: General, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 735946

People

(Reporter: Alexander_Pircher, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20120312 Firefox/11.0 SeaMonkey/2.8
Build ID: 20120312220748

Steps to reproduce:

Clicking on a link within an external application, e.g. a link in an OpenOffice.org Writer Document.


Actual results:

Browser opened link, but external application was still focused.


Expected results:

Browser should get focused (behaviour in 2.7 and before)
I'll confirm the change in behavior.
Current behavior is different from FF 11, so will assume it is a bug.
Confirmed on XP SP3 and Win 7 SP1.
Confirmed on Win7 x64 (again), used to work with the previous 2.7.
Same here in WinXP
Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20120320 Firefox/14.0a1 SeaMonkey/2.11a1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: SeaMonkey 2.8 Branch → Trunk
Confirmed on Win7 X64
Duplicate of this bug: 739034
I might just add, that while this is a bug, a preference sure would be nice to retain the buggy behavior or to run the fix.

As monitors become larger (wider, really), this (current buggy behavior) can (depending obviously) work out well actually.  Like I keep cZ open, about 1/3 screen width.  Browser windows are set wider.  Opening consecutive links from within cZ is very convenient because focus stays at cZ, & with the widths I have chosen, I can still monitor the tabs opening in the browser window.

So a preference to open as it should, or to open broken would be nice.
Duplicate of this bug: 740023
Same problem on XP and Windows 7.

The problem is also still there in SeaMonkey 2.9 Beta 1.

I had to re-install version 2.7.2 in order to get back to the behaviour of what a default browser should be  (come to the fore when the user clicks a link from an external program).
Could this be related to bug 735946 ?
> Could this be related to bug 735946 ?
Probably. Setting Dependency.
Depends on: 735946
(In reply to therube from comment #7)
> I might just add, that while this is a bug, a preference sure would be nice
> to retain the buggy behavior or to run the fix.
I think the intent is that if you have set the preference to open such links in background tabs then they will not cause the browser to get focused.
Summary: Browser is not not focused when clicking links in external applications → Browser is not not focused when opening links from external applications
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 735946
Seems to have been fixed in SM 2.9
You need to log in before you can comment on or make changes to this bug.