Mozilla will not restart after having been running for a while. Start it, browse, and close it down, and it will not restart. Why does this window keep telling me that my summary isn't descriptive enough - surely a summary should be short?



UI Design
17 years ago
14 years ago


(Reporter: john, Assigned: Bill Law)



Windows ME

Firefox Tracking Flags

(Not tracked)



(1 attachment)



17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Win95; U)
BuildID:    20010327

After running Mozilla for a while, browsing sites, etc, if I shut it down and 
then try to restart it, it will not restart. There will be a process in task 
manager (multiple processes if I try to re-start multiple time) but the browser 
window never opens

Reproducible: Always
Steps to Reproduce:
1.Start Mozilla and browse with other apps running.
2.Shut Mozilla down
3.Restart Mozilla - will not open windows though process is running.

Actual Results:  Mozilla will intermittently not restart after being shutdown.

Expected Results:  Mozilla should be able to restart after a session

Is intermittent, but easily reproducable with some extended browsing in the 
first session.  This has been happening since the first Mozilla release. Is 
still happening with 0.8.1 full release.

Comment 1

17 years ago
dupe of bug 53952 ?

Comment 2

17 years ago
Can you verify in the task manager that when you close mozilla that the process
exits before you restart it.

Very often after a long usage Mozilla closes its windows but the process lives on.

[Why do i not see the extra info that the reporter just added when adding this
reply to it??]

Comment 3

17 years ago
Hmm, could be similar, maybe even the same cause, but I've had it happen when
there are no other Win32 apps that are frozen.

Reading further down it could be the same DDE problem, as I can see the mutliple
Mozilla processes in the taskmanager, so it seems to be some kind of system
blocking problem. However I think the main difference is that I can start
Mozilla, browse, shut Mozilla down completely and then it won't start again. 

I'll have to double-check to see if the Mozilla process is still running on
restart, but I don't think so. If I try to restart twice, there are only two
Mozillas in the task manager. There would be three if once was still going.

Comment 4

17 years ago
i'm more willing to bet that this is a dupe of mozilla not quiting when it's 
told to.

Comment 5

17 years ago
I've double-checked as requested. After shutting down Mozilla I check the
taskmanager to make sure there are no rougue Mozilla processes left. I try to
restart, a new Mozilla process appears in taskmanager, but no Mozilla window opens.

If I attempt to start Mozilla multiple times, I get multiple instances in the
taskmanager, but no Mozilla window. The only way to fix this is to reboot the

Comment 6

17 years ago
please try following 
the steps at
create two dwi files, one of when mozilla works, and one of when it doesn't.  
zip the two files and attach the zip here as mime type: application/zip

Comment 7

17 years ago
I've now noticed that if Mozilla enters this "refusing to restart" state, and I
start multiple copies, all but the first instance will disappear from the
taskmanager after about 30 seconds (version 0.8.1)

Comment 8

17 years ago
Created attachment 29046 [details]
zip file containing two dwi files

Comment 9

17 years ago
00:00:03.000: Loaded "c:\win95\TRAYHOOK.DLL" at address 0x20420000 by thread 1. 
 Successfully hooked module.
00:00:03.041: DllMain(0x20420000, DLL_PROCESS_ATTACH, 0x00000000) in 
"c:\win95\TRAYHOOK.DLL" called by thread 1.
00:00:03.045: GetProcAddress(0x7FBD0000 [c:\win95\system\SHELL32.DLL], 
"Shell_NotifyIconA") called from "c:\win95\TRAYHOOK.DLL" at address 0x204219AE 
and returned 0x7FC0F1BE by thread 1.
00:00:03.062: GetProcAddress(0x7FBD0000 [c:\win95\system\SHELL32.DLL], 
"Shell_NotifyIconW") called from "c:\win95\TRAYHOOK.DLL" at address 0x204219AE 
and returned 0x7FBF8D82 by thread 1.
00:00:03.066: GetProcAddress(0x7FBD0000 [c:\win95\system\SHELL32.DLL], 
"Shell_NotifyIcon") called from "c:\win95\TRAYHOOK.DLL" at address 0x204219AE 
and returned 0x7FC0F1BE by thread 1.
00:00:03.068: DllMain(0x20420000, DLL_PROCESS_ATTACH, 0x00000000) in 
"c:\win95\TRAYHOOK.DLL" returned 1 (0x1) by thread 1.
>we die here< before we \v\create any additional threads/v/
00:00:03.100: Thread 2 started in "c:\program 
files\\mozilla\MOZILLA.EXE" at address 0x004034D2.
00:00:03.102: DllMain(0x78000000, DLL_THREAD_ATTACH, 0x00000000) in 
"c:\win95\system\MSVCRT.DLL" called by thread 2.
00:00:03.104: DllMain(0x78000000, DLL_THREAD_ATTACH, 0x00000000) in 
"c:\win95\system\MSVCRT.DLL" returned 1 (0x1) by thread 2.

-this is going to drop off my radar for a bit while i try to collect other hang 
datapoints. no guarnatees for a few weeks. ping me if n.othing happens by may 
Assignee: asa → law
Component: Browser-General → XP Apps
Keywords: hang

Comment 10

17 years ago
Ugh, I hate this bug. timeless, can you please look at again? It happens very 
consistantly for me when I am in Windows ME. I was hoping it was a 0.8.x 
problem, but today's nightly confirmed that it is still is there. I can provide 
debug info too, if necessary...

Comment 11

17 years ago
timeless, sorry for adding you to the CC list. Bugzilla is too smart for me 
now. Removing one of your addresses.

Comment 12

17 years ago
There are some reports of trayhook.dll interfering with Mozilla on WinME....not
sure if thats the link or not. Marking NEW.
Ever confirmed: true

Comment 13

17 years ago
This is your May ping as requested ;)

This problem is still happening as of 28th April's Nighly Build

Comment 14

17 years ago
wow, not bad timing, please try the patch in bug 53952.
ideally it skirts the issue entirely.

Comment 15

17 years ago
Is this being built into the nightlies (and if so as of when)?

I'm not a developer so I can't build the code, but I can check the binaries.

Please don't tell me it was in the 01 May build as this just crashed on startup with GKDlayout.dll errors. :(

Otherwise I'll download and check it when I get home in about eight hours....

Comment 16

17 years ago
nope it's not r/sr/committed

Comment 17

17 years ago
Can you update when it is checked in? Then I'll download and test ASAP.


Comment 18

17 years ago
I've just downloaded the latest nightly (ID 20010504) and I can't reproduce the
bug anymore. I've only been trying for a couple of hours, but under
circumstances that I would expect to show the problem fairly quickly. Something
has definately changed in the code that has prevented this bug from showing (at
least on my system). 

I'll keep checking and update again in the next few days.


Comment 19

17 years ago
Nope, the bug is still there - I got it to hang again in the same manner with the 20010504. It does seem to be harder to do now though.

Please update when your new code has been built into the nightlies and I'll test again.

Comment 20

17 years ago
nav triage team:

Marking nsbeta1+ and p2 and mozilla0.9.2
Keywords: nsbeta1+
Priority: -- → P2
Target Milestone: --- → mozilla0.9.2

Comment 21

17 years ago
This seems to have been fixed by the recent fix of 53952. Although the symptoms
were a bit different, looks the the cause was the same and I can no longer
reproduce this error.  
looks like this is all better now thanks to the DDE fix in bug 53952. WFM. 
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.