Filter editor dialog does not fit all UI elements

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: jashank.jeremy, Unassigned)

Tracking

13 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 606774 [details]
Screenshot demonstrating the issue

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120310173008

Steps to reproduce:

In Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0) Gecko/20120315 Thunderbird/13.0a2 ID:20120315030021 
- Open the Message Filter dialog (Tools -> Message Filters), then
- Either create or edit a message filter.


Actual results:

The FilterEditor UI does not display with the correct dimensions, and user interface elements are invisible (including the OK and Cancel buttons).


Expected results:

The entire FilterEditor UI should be displayed.
(Reporter)

Updated

7 years ago
Component: General → Mail Window Front End
QA Contact: general → front-end

Comment 1

7 years ago
If you resize the window manually, does it keep the size at subsequest opens?
(Reporter)

Comment 2

7 years ago
(In reply to :aceman from comment #1)
> If you resize the window manually, does it keep the size at subsequest opens?

Hmm.  It's not directly obvious that the dialog is resizeable, but yes, the dialog does maintain it's dimensions across reopening and restarting Earlybird.  I note that the issue also presents with a clean profile, and can be resolved in a similar way.

Is it possible to add some user interface element to it to make it more obvious that the dialog is resizeable?

Comment 3

7 years ago
Yeah, that dialog is a bit non-standard. Is there a resizer corner in the filter list window on your system?

But the real problem here is why would it be so small even in clean profile? Can your window manager interfere and set the initial size?
(Reporter)

Comment 4

7 years ago
I'm not sure; I'm sure that the OS X window manager could certainly make a mess of it.  What I find more concerning is that I cannot find any other dialogs in any application on my system that can be resized by grabbing the borders.  There isn't any sign of a resize grip, or anything else for that matter, until one hovers over the edge of the window.

Comment 5

7 years ago
That is true. As I said, that dialog is different from other windows (by looking into the code). As a dialog it should probably not be resizable. It should be a normal window with a resizer. But there may be some legacy reasons why it is implemented in that way. I can confirm it does not have a resizer grip on Linux and Windows too. But this is a problem for another bug, it would be nice if you file it.
(Reporter)

Comment 6

7 years ago
Bug filed, #737796.
(Reporter)

Updated

7 years ago
See Also: → bug 737796

Comment 7

7 years ago
Thanks, so now back to the original issue. Can you find any more indices when does the dialog come out so wrongly small? I have no experience with Mac OS X, CCing bwinton.
(Reporter)

Comment 8

7 years ago
It's highly plausible that there's some preference issue buried away somewhere, but I'm not sure where to look (my background is Linux and BSD, and OS X is still relatively new to me).

Comment 9

7 years ago
Yes, but we need to find out if it is TB setting and storing the preference (window size) or it is something else.
TB stores the sizes of all its windows in its profile and restores them on next window open. But when you see it in clean profile then it is strange where should be nothing to restore from.

Updated

6 years ago
Component: Mail Window Front End → Filters

Updated

3 years ago
Blocks: 771652
Duplicate of this bug: 771652

Comment 11

3 years ago
Does this still occur in version 45?
Severity: normal → minor
Flags: needinfo?(webmaster2)
Flags: needinfo?(jashank.jeremy)

Comment 12

2 years ago
Eckard, does this reproducefor you?
Flags: needinfo?(webmaster2)
Flags: needinfo?(jashank.jeremy)
Flags: needinfo?(e.berberich)

Comment 13

2 years ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #12)
> Eckard, does this reproducefor you?
No, I can't reproduce this issue.
Flags: needinfo?(e.berberich)

Comment 14

2 years ago
I cannot reproduce it.  When I size the dialog box small, I can still see the vertical scroller on the right.  When I originally reported 771652, this was not the case.

Thunderbird 45.6.0.  Mac OS X 10.11.6.

JC

Comment 15

2 years ago
JC, Eckard thanks for the test.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.