After msg pane snapped open, new selections don't load content

VERIFIED FIXED in mozilla0.9

Status

SeaMonkey
MailNews: Message Display
P2
normal
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Dan Rosen, Assigned: varada)

Tracking

({regression})

Trunk
mozilla0.9
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

(Reporter)

Description

17 years ago
You probably have a bug filed on messages in the mail window not displaying the
header info already... There is an additional problem where, when that happens,
if you try to click on the grippy to collapse and re-expand the message pane (to
try to get the header info to draw), the header info draws properly but then you
can't select/view any more messages in that folder.

...In other words:

STEPS TO REPRODUCE:
1) Switch to a folder with unread messages, open one of them.
2) The header info for that message should theoretically display, but doesn't.
3) Click on the grippy to collapse the message pane, click it again to re-expand it.
4) The header info should now display.
5) Try to click on other messages in the folder, to view them. It doesn't work.
You have to switch to a different folder and come back to view other messages.

Note also that if you do not attempt to force the header info to display, this
problem does not appear.

This is reproducable always, on all platforms, since the mailnews branch landing.

Comment 1

17 years ago
The problem about the header envelope not displaying is bug 39655.  
I'm changing the summary of this bug to reflect the selection problem after
snapping the message pane shut/open.
QA Contact: esther → laurel
Summary: Problems when message in mail window doesn't display header → After msg pane snapped open, new selections don't load content

Updated

17 years ago
Keywords: nsbeta1, regression
(Reporter)

Comment 2

17 years ago
setting bug 39655 as dependency, assuming if that goes away then this will...
Depends on: 39655

Updated

17 years ago
Priority: -- → P2
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9

Comment 3

17 years ago
Steps 1+2 seem like a dup of the bug mention but the rest of the steps describe
this bug which I am also able to reproduce.  I thought we had a bug on this but
I couldn't find it.  So, marking nsbeta1+

Comment 4

17 years ago
*** Bug 74989 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

17 years ago
Re-assigning to varada
Assignee: sspitzer → varada
(Assignee)

Comment 6

17 years ago
Adding Eric Vaughan to the bug. 
This behaviour is happening because the splitter is not throwing back proper
state values.i.e. open when closed and vice versa.
(Assignee)

Comment 7

17 years ago
Marking Fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
OK using apr17 commercial trunk build: linux rh6.2, win98, mac OS 9.0
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.