add a way to report missing words in the spell checker

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: amir.aharoni, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:12.0a2) Gecko/20120307 Firefox/12.0a2
Build ID: 20120307075804

Steps to reproduce:

The spell checker found a word that it didn't recognize and marked it in red. I right-clicked it.


Actual results:

I had the option "Add to dictionary". This option adds the word to my local private dictionary.


Expected results:

There should be an option to not just add the word to my private dictionary, but also to report the word to the maintainer of the dictionary. This is especially important for  languages which are not as major as English and French. English has pretty complete spelling dictionaries and many rare words are, in fact, intentionally not included in the Firefox English spelling dictionary to keep it smaller. This is OK for English, but for many languages the spelling dictionary is far from being complete, so they can benefit from crowd-sourcing the reporting of missing words.

Consider this a feature request.

Comment 1

7 years ago
Moving to Core -> Spelling Checker for lack of a better place to put it. If you are wanting too help with a specific localization that would be a different component
Severity: normal → enhancement
Component: Untriaged → Spelling checker
Product: Firefox → Core
QA Contact: untriaged → spelling-checker
Version: 12 Branch → Trunk
(Reporter)

Comment 2

7 years ago
(In reply to Tim (fmdeveloper) from comment #1)
> Moving to Core -> Spelling Checker for lack of a better place to put it.

Thank you, it should be OK.

> If you are wanting too help with a specific localization that would be a
> different component

No, this is a general thing that should be done for all languages. I've been exchanging emails with word corrections and additions with the developers of the spelling dictionary for my language, Hebrew, for years, and as a result they added or corrected quite a lot of words. Precisely because of this i think that this process should be more streamlined.

Comment 3

7 years ago
This sounds like a great idea for an add-on, but I don't think we want to include such UI in core Firefox because of two reasons:

1. Finding a unified way to suggest missing words to dictionary maintainers may be challenging.

2. Regular users who do not wish to contribute to their language's dictionary shouldn't see a menu item to do so, and those users constitute the majority of our users.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

7 years ago
I won't argue with the resolution, but i just have to argue with the reasoning.

1. Finding a unified way for triaging such reports is very easy. I already wrote most of the spec for such a thing yesterday and started implementing a prototype in Perl. Maybe i should have opened this bug after finishing it, but i was eager to share the basic idea. See http://aharoni.wordpress.com/2012/03/18/the-secret-spell-how-to-easily-make-spelling-checkers-better/ .

2. Why do you think that the majority of users do not wish to contribute to their language's dictionary? Was it ever asked in a survey? Almost any user can report a spelling mistake if it's as easy as pressing "Add to dictionary" (it can be anonymous, so there are no privacy concerns). The number of people who can and want to report missing words in a spelling dictionary is much higher than the number of people who will ever want to use the developer tools, yet all the users see the "Inspect element" menu item.

Comment 5

7 years ago
(In reply to Amir Aharoni from comment #4)
> I won't argue with the resolution, but i just have to argue with the
> reasoning.
> 
> 1. Finding a unified way for triaging such reports is very easy. I already
> wrote most of the spec for such a thing yesterday and started implementing a
> prototype in Perl. Maybe i should have opened this bug after finishing it,
> but i was eager to share the basic idea. See
> http://aharoni.wordpress.com/2012/03/18/the-secret-spell-how-to-easily-make-
> spelling-checkers-better/ .

Well, it's not all about the code for the tool.  Communicating the suggestions to the dictionary maintainer, getting them into the dictionaries, testing the dictionaries to make sure they work correctly (badly formatted dictionaries can crash Firefox :/ ), updating them on AMO, etc.

> 2. Why do you think that the majority of users do not wish to contribute to
> their language's dictionary? Was it ever asked in a survey?

I could ask the same question from you.  :-)  I'm judging from my experience with the l10n teams, specifically about how many people from each locale would volunteer to contribute to l10n projects from the total population of users on that locale.

> Almost any user
> can report a spelling mistake if it's as easy as pressing "Add to
> dictionary" (it can be anonymous, so there are no privacy concerns). The
> number of people who can and want to report missing words in a spelling
> dictionary is much higher than the number of people who will ever want to
> use the developer tools, yet all the users see the "Inspect element" menu
> item.

Our developer tools target the web developer community, which I think is much larger than the potential spelling suggestion community.  And really these are two very different set of tools...

Note that I'm not opposing your idea at all.  In fact I would very much like to see an add-on which does this and I'd really hope that you prove me wrong on both of these fronts.  :-)  But until that happens, I don't think we should ship this experiment in core Firefox.
You need to log in before you can comment on or make changes to this bug.