Last Comment Bug 736890 - Speed up building of layout/svg/base/src by cleaning up #include directives in its header files
: Speed up building of layout/svg/base/src by cleaning up #include directives i...
Status: RESOLVED FIXED
[include-what-you-use]
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Jonathan Watt [:jwatt] (catching up after vacation)
:
Mentors:
Depends on:
Blocks: 738969 iwyu
  Show dependency treegraph
 
Reported: 2012-03-18 14:45 PDT by Jonathan Watt [:jwatt] (catching up after vacation)
Modified: 2013-08-11 03:18 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (41.42 KB, patch)
2012-03-18 14:45 PDT, Jonathan Watt [:jwatt] (catching up after vacation)
no flags Details | Diff | Splinter Review
patch (45.32 KB, patch)
2012-03-18 15:26 PDT, Jonathan Watt [:jwatt] (catching up after vacation)
dholbert: review+
Details | Diff | Splinter Review

Description Jonathan Watt [:jwatt] (catching up after vacation) 2012-03-18 14:45:56 PDT
Created attachment 607009 [details] [diff] [review]
patch

This is the equivalent of bug 721131, but for layout/svg/base/src header files. This patch cleans up the header files to make them include what they use, and nothing more.

For me, I get a 13% speed up for a warm, full rebuild in that directory.
Comment 1 Jonathan Watt [:jwatt] (catching up after vacation) 2012-03-18 15:26:58 PDT
Created attachment 607014 [details] [diff] [review]
patch

Turns out there were a few other places outside of the SVG code that were depending on SVG headers to include headers that they need.
Comment 2 Daniel Holbert [:dholbert] 2012-03-19 16:11:10 PDT
Comment on attachment 607014 [details] [diff] [review]
patch

Looks good to me.

I didn't bother to verify that all the added #includes and 'class'/'struct' declarations are actually necessary -- I'm trusting you and the include-what-you-use tool on that.

(Plus, even if this did add an extraneous #include or declaration, it shouldn't really cause any problems, and this would still be a net win.)
Comment 3 Mounir Lamouri (:mounir) 2012-03-21 03:45:13 PDT
https://hg.mozilla.org/mozilla-central/rev/c64ab2ce86a0

Note You need to log in before you can comment on or make changes to this bug.