Last Comment Bug 736898 - Avoid signed/unsigned comparisons in tools/profiler
: Avoid signed/unsigned comparisons in tools/profiler
Status: RESOLVED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: Gecko Profiler (show other bugs)
: Trunk
: x86_64 Windows 7
: -- trivial (vote)
: mozilla14
Assigned To: Brian Smith (:briansmith, :bsmith, use NEEDINFO?)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-18 16:16 PDT by Brian Smith (:briansmith, :bsmith, use NEEDINFO?)
Modified: 2012-04-05 11:26 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Avoid signed/unsigned comparisons in tools/profiler (1.54 KB, patch)
2012-03-18 16:16 PDT, Brian Smith (:briansmith, :bsmith, use NEEDINFO?)
bgirard: review+
Details | Diff | Splinter Review

Description Brian Smith (:briansmith, :bsmith, use NEEDINFO?) 2012-03-18 16:16:15 PDT
Created attachment 607026 [details] [diff] [review]
Avoid signed/unsigned comparisons in tools/profiler

These signed/unsigned comparisons cause MSVC to complain. The comparison in the header is particularly annoying because that header is included by code that uses the profiler (e.g. Necko).
Comment 1 Benoit Girard (:BenWa) 2012-03-21 06:58:41 PDT
Thanks Brian
Comment 2 Brian Smith (:briansmith, :bsmith, use NEEDINFO?) 2012-04-04 19:19:57 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/3355f91a501f

Note You need to log in before you can comment on or make changes to this bug.