The default bug view has changed. See this FAQ.

Java applet would not run on certain site

RESOLVED FIXED

Status

()

Core
Plug-ins
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Alice0775 White, Assigned: johns)

Tracking

({regression})

unspecified
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox13+ unaffected, firefox14+ unaffected, firefox15+ unaffected, firefox16+ unaffected)

Details

(Reporter)

Description

5 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/e94edfdb1f5b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120318 Firefox/14.0a1 ID:20120318031036
http://hg.mozilla.org/releases/mozilla-aurora/rev/79655c8b3351
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120317 Firefox/13.0a2 ID:20120317042020

I encounter a problem when I test Bug 640843.
Java applet would not run on certain site.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox with new profile + Java(TM) Platform SE 6 U31
2. Open http://people.cs.ubc.ca/~poole/demos/localization/localization.html

Actual Results:
 Java applet would not run.

Expected Results:  
 Java applet run. 

Regression window(m-c),
Works:
http://hg.mozilla.org/mozilla-central/rev/30b4f99a137c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120229 Firefox/13.0a1 ID:20120229031108
Fails:
http://hg.mozilla.org/mozilla-central/rev/3812d0ce274e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120229 Firefox/13.0a1 ID:20120229104909
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=30b4f99a137c&tochange=3812d0ce274e


Regression window(m-i),
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/9b7d19dbb281
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120228 Firefox/13.0a1 ID:20120228171549
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/1e4675fb8fc9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120228 Firefox/13.0a1 ID:20120228205509
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9b7d19dbb281&tochange=7c29df99aad7
Suspected:
1e4675fb8fc9	John Schoenick — Bug 406541 - Ensure we agree with java on applet codebase, and run security checks for file: codebase URIs. r=jst

Updated

5 years ago
Keywords: regression
Blocks: 406541
tracking-firefox13: --- → ?
tracking-firefox14: --- → ?
(Assignee)

Updated

5 years ago
Assignee: nobody → jschoenick

Comment 1

5 years ago
This is very important to track since we know that java applets are still used significantly in our GA (see bug 718939). Thanks bz.
tracking-firefox13: ? → +
tracking-firefox14: ? → +
Blocks: 741758
(Assignee)

Updated

5 years ago
Depends on: 745030
(Assignee)

Updated

5 years ago
OS: Windows 7 → All
Hardware: x86 → All
(Assignee)

Comment 2

5 years ago
The culprit was backed out of aurora so this only affects 14+ now

http://hg.mozilla.org/releases/mozilla-aurora/rev/96a1b7f055c9
status-firefox13: --- → unaffected
status-firefox14: --- → affected
Version: 13 Branch → 14 Branch
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Duplicate of this bug: 744898
(Assignee)

Updated

5 years ago
Duplicate of this bug: 763298

Comment 5

5 years ago
(In reply to John Schoenick [:johns] from comment #2)
> The culprit was backed out of aurora so this only affects 14+ now
> 
> http://hg.mozilla.org/releases/mozilla-aurora/rev/96a1b7f055c9

Can we back out of all branches if we don't plan to resolve any time soon? Do we expect add-on compatibility to break with the UUID change in the backout?
(Assignee)

Comment 6

5 years ago
(In reply to Alex Keybl [:akeybl] from comment #5)
> (In reply to John Schoenick [:johns] from comment #2)
> > The culprit was backed out of aurora so this only affects 14+ now
> > 
> > http://hg.mozilla.org/releases/mozilla-aurora/rev/96a1b7f055c9
> 
> Can we back out of all branches if we don't plan to resolve any time soon?
> Do we expect add-on compatibility to break with the UUID change in the
> backout?

{reposting from bug 741778}

Bug 406541 was backed out of 14 as well:
http://hg.mozilla.org/releases/mozilla-beta/rev/4782adb17edf

Bug 745030 will be the proper fix for 406451 regressions. I had hoped to land in 15, but is now looking more involved. I'll know by the end of next week if it will be landing on 16 - If not, I can back 406541 out of trunk along with 15 and reland it when the fix is ready

The interface change is only removing one function that's likely not of interest to addons. The 15+ backout can use 14's UUID
status-firefox14: affected → unaffected
status-firefox15: --- → affected
status-firefox16: --- → affected
tracking-firefox15: --- → ?
tracking-firefox16: --- → ?
Version: 14 Branch → 15 Branch

Updated

5 years ago
tracking-firefox15: ? → +
tracking-firefox16: ? → +
(Assignee)

Comment 7

5 years ago
Bug 406541 has been backed out of all branches, so this regression should be no more
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-firefox15: affected → unaffected
status-firefox16: affected → unaffected
Resolution: --- → FIXED
Version: 15 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.