Need to point to Java Plugin download page for HPUX

VERIFIED FIXED in mozilla0.9.1

Status

SeaMonkey
General
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Shannon Diener, Assigned: Shannon Diener)

Tracking

Trunk
mozilla0.9.1
HP
HP-UX

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; HP-UX B.11.00 9000/785; en-US; m18)
Gecko/20010214 Netscape6/6.01
BuildID:    Netscape_6_0_OEM_BRANCH

Currently, if you encounter a page requiring java and you don't have the plugin,
a window pops up saying:

"This page contains information of type (application/x-java-vm) that can only be
viewed  with the appropriate Plug-in. Click OK to download Plugin"

After you click OK you are taken to: http://home.netscape.com/plugins/jvm.html
where you can download the plugin for windows or linux.

On HPUX we need this link to take us to where we can download a plugin for HPUX.



Reproducible: Always
Steps to Reproduce:
1. go to http://java.sun.com
2. if you don't have a java plugin installed a dialog box pops up telling you
that you don't have a java plugin and to press okay to install one
3. Press OK - you are taken to http://home.netscape.com/plugins/jvm.html
where you can install the plugin for windows or linux

Actual Results:  You go to http://home.netscape.com/plugins/jvm.html


Expected Results:  If the browser is running on HPUX it needs to go to a site to
install the java plugin for HPUX

The URL is hardcoded in mozilla/modules/plugin/default/unix/nullplugin.h

Below is a diff to change this hardcoded URL.
I don't know the URL for where to download the Java Plugin for HPUX yet so I
used "http://www.hp.com"

 Index: nullplugin.h
===================================================================
RCS file: /cvsroot/mozilla/modules/plugin/default/unix/nullplugin.h,v
retrieving revision 1.1.8.1
diff -u -r1.1.8.1 nullplugin.h
--- nullplugin.h        2000/10/10 22:52:42     1.1.8.1
+++ nullplugin.h        2001/03/28 00:45:22
@@ -43,7 +43,11 @@
 #define PLUGINSPAGE_URL     "http://cgi.netscape.com/cgi-bin/plug-in_finder.cgi"
 #define OK_BUTTON           "OK"
 #define CANCEL_BUTTON       "CANCEL"
-#define JVM_SMARTUPDATE_URL "http://home.netscape.com/plugins/jvm.html"
+#if defined (HPUX)
+#define JVM_SMARTUPDATE_URL "http://www.hp.com"
+#else
+#define JVM_SMARTUPDATE_URL "http://home.netscape.com/plugins/jvm.html"
+#endif /*HPUX*/
 #define JVM_MINETYPE        "application/x-java-vm"
 #define MESSAGE "\
 This page contains information of a type (%s) that can\n\
(Assignee)

Updated

18 years ago
Blocks: 18687
QA Contact: doronr → barrettl

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 1

18 years ago
Shouldn't you point them to something other than hp.com?
Didn't HP tell us what the java url will be?
Going to hp.com is confusing... at least to me.
(Assignee)

Comment 2

18 years ago
Using http://www.hp.com is not the permanent solution.  I'm using it in the diff
right now since I do not know the correct URL.  Once I know the correct URL, I
will replace the www.hp.com.  I posted the diff this way so that if anybody saw
anything else wrong, they could comment.  I realize that this was not clear and
I apologize for the confusion.

Comment 3

18 years ago
The URL to use for the java plugin is:
http://www.hp.com/go/java
(Assignee)

Comment 4

18 years ago
This is an updated diff with the new URL:

Index: nullplugin.h
===================================================================
RCS file: /cvsroot/mozilla/modules/plugin/default/unix/nullplugin.h,v
retrieving revision 1.1.8.1
diff -u -r1.1.8.1 nullplugin.h
--- nullplugin.h        2000/10/10 22:52:42     1.1.8.1
+++ nullplugin.h        2001/03/29 01:27:27
@@ -43,7 +43,11 @@
 #define PLUGINSPAGE_URL     "http://cgi.netscape.com/cgi-bin/plug-in_finder.cgi"
 #define OK_BUTTON           "OK"
 #define CANCEL_BUTTON       "CANCEL"
-#define JVM_SMARTUPDATE_URL "http://home.netscape.com/plugins/jvm.html"
+#if defined (HPUX)
+#define JVM_SMARTUPDATE_URL "http://www.hp.com/go/java"
+#else
+#define JVM_SMARTUPDATE_URL "http://home.netscape.com/plugins/jvm.html"
+#endif /*HPUX*/
 #define JVM_MINETYPE        "application/x-java-vm"
 #define MESSAGE "\
 This page contains information of a type (%s) that can\n\



For all requests for mimetype application/x-java-vm the user will be sent to
"http://www.hp.com/go/java" when agreeing to download the plugin
(Assignee)

Comment 5

18 years ago
New diff - just changed #if defined (HPUX) to #ifdef HPUX

Index: nullplugin.h
===================================================================
RCS file: /cvsroot/mozilla/modules/plugin/default/unix/nullplugin.h,v
retrieving revision 1.1.8.1
diff -u -r1.1.8.1 nullplugin.h
--- nullplugin.h        2000/10/10 22:52:42     1.1.8.1
+++ nullplugin.h        2001/03/29 18:46:47
@@ -43,7 +43,11 @@
 #define PLUGINSPAGE_URL     "http://cgi.netscape.com/cgi-bin/plug-in_finder.cgi"
 #define OK_BUTTON           "OK"
 #define CANCEL_BUTTON       "CANCEL"
-#define JVM_SMARTUPDATE_URL "http://home.netscape.com/plugins/jvm.html"
+#ifdef HPUX
+#define JVM_SMARTUPDATE_URL "http://www.hp.com/go/java"
+#else
+#define JVM_SMARTUPDATE_URL "http://home.netscape.com/plugins/jvm.html"
+#endif /*HPUX*/
 #define JVM_MINETYPE        "application/x-java-vm"
 #define MESSAGE "\
 This page contains information of a type (%s) that can\n\

Comment 6

18 years ago
r=jgaunt cool for the branch. 

Comment 7

18 years ago
r=edburns
(Assignee)

Comment 8

18 years ago
Checked into Netscape_6_0_OEM_BRANCH
a=mtchan
(Assignee)

Comment 9

17 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

17 years ago
reopening for trunk
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

17 years ago
Created attachment 34102 [details] [diff] [review]
patch for the trunk
(Assignee)

Comment 12

17 years ago
If this looks okay, to everyone, I'm going to ask for review
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.1

Comment 13

17 years ago
ra=av
(Assignee)

Comment 14

17 years ago
checked in
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 15

17 years ago
Verified on build #2001052021 on hpux 11i.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.