Door hanger still appears when reloading website even if "Always Show" for popups is tapped

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: xti, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Firefox 14.0a1 (2012-03-19)
Device: Samsung Nexus S
OS: Android 2.3.6

Steps to reproduce:
1. Open Fennec
2. Perform the steps from Bug 737073 for several times. When Fennec goes to background, just bring it back in focus and close all popup tabs and open http://www.popuptest.com/popuptest1.html from History (it's easier and quicker).
3. After a couple of tries the door hanger will be displayed for the website mentioned at step 2. Tap on "Always Show" button.
4. Reload the webpage

Expected result:
The popups will be automatically opened each one in a new tab, after step 4.

Actual result:
1. First, the door hanger should not be displayed since it was dismissed once with "Always show" option.
2. After step 4, the door hanger will be triggered again. At this point, steps 3 and 4 can be performed forever.

Note:
Please see this video: http://youtu.be/yFchnOY_KhQ

Updated

6 years ago
Summary: Door hanger still appears when reloading website even if "Always Show" button is tapped → Door hanger still appears when reloading website even if "Always Show" for popups is tapped

Comment 1

6 years ago
This may be caused by bug 713062. I haven't looked into it closely, though.
Blocks: 744060
No longer blocks: 744060

Comment 2

6 years ago
I couldn't reproduce this. Cristian, are you still seeing this? Maybe the fix for bug 743227 fixed it.
I can no longer reproduce this issue.  Nicolae, can you retest please?
(Reporter)

Comment 4

6 years ago
(In reply to Margaret Leibovic [:margaret] from comment #2)
> I couldn't reproduce this. Cristian, are you still seeing this? Maybe the
> fix for bug 743227 fixed it.

(In reply to Naoki Hirata :nhirata from comment #3)
> I can no longer reproduce this issue.  Nicolae, can you retest please?

I cannot reproduce this either. I am almost sure, as Margaret said, that the fix for bug 743227 has fixed this bug too. 

--
Firefox 14.0a1 (2012-04-17)
Device: Samsung Galaxy S (Captivate)
OS: Android 2.2
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Depends on: 743227
You need to log in before you can comment on or make changes to this bug.