If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Meaningful errors in the RestructuredText parser

RESOLVED WONTFIX

Status

Mozilla Reps
reps.mozilla.org
--
enhancement
RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: stephend, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
On https://reps-dev.allizom.org/u/fredy/, there are a few Python error messages, like so:

System Message: WARNING/2 (<string>, line 49); backlink
Duplicate explicit target name: "august".

System Message: ERROR/3 (<string>, line 52)
Document may not end with a transition.
Docutils System Messages

System Message: ERROR/3 (<string>, line 38); backlink
Duplicate target name, cannot be used as a unique reference: "august".

System Message: ERROR/3 (<string>, line 40); backlink
Unknown target name: "image".

System Message: ERROR/3 (<string>, line 45); backlink
Unknown target name: "python".
(Reporter)

Comment 1

6 years ago
Created attachment 607248 [details]
Screenshot
Hey Stephen,

thanks for reporting this. Fredy is a great guy who helps us with QA on our end ;) He spent a couple of hours testing the restructuredtext support in our website, as you can see.

Regarding the error, this is to notify you that your restructuredtext is broken and it's generated from the django markup module. I understand it's not beautiful but this is intended behavior when your input in incorrect. It's not an error in our code. 

Additionally restructuredtext support is still a "hidden" feature in our website, we don't advertise it so most reps won't even notice ;)

That being said I downgrade this bug to normal and I leave it open so in the future we can display nicer error messages when your markup is invalid. 

Thanks!
Severity: critical → normal
Version: 0.2 - Skon → unspecified
Duplicate of this bug: 737524
(Reporter)

Comment 4

6 years ago
Thanks, Giorgos, for the explanation; makes perfect sense!
Severity: normal → enhancement
Summary: Python system errors on "fredy" user page → Meaningful errors in the RestructuredText parser
We are now using MarkDown as a syntax markup, so closing this bug
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.