Mail composition hotkeys are not functional for Subject and Attachments.

RESOLVED WORKSFORME

Status

MailNews Core
Composition
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Wesley George, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
<summary>
Mail composition hotkeys are not functional for Subject and Attachments.

<repro environment>
build 03-27-06 + NT4.0

<repro steps>
-open mail
-open a new message
-place focus in the address field or the message body
-press ALT + S
-press ALT + A

<result>
nothing happens

<expected result>
There are two string in the UI, "Subject:" and "Attachments:" with underlined 
letters "S" and "A" that are apparent hot keys (since they're not present on 
the MAC build.  

The ALT key combination should move focus to the respective area.  Otherwise, 
the underlines should be removed.
-->varada
Assignee: ducarroz → varada

Comment 2

16 years ago
changing qa to olgam, she has menus.  Note: in the description, the reporter is
using ALT+S and Alt+A.    In build 20020220 on winxp, in the Compose window,
Alt+F brings up the File menu list so the mnemonic keys will work for that menu
list.  Pressing the "a" key brings up the Save As dialog, pressing "s" does  a
save of the message to the drafts folder.   This is correct behavior.  Wesley,
if there are steps we're not using correctly please write them.  If this is now
working for you with current builds, please make a note in this bug.
QA Contact: esther → olgam
taking all of varada's bugs.
Assignee: varada → sspitzer

Comment 4

15 years ago
I am puzzled by comment 2; the file menu does not apply to this bug at all: 
there are no items in any part of the menu designed to shift focus to a field, 
which is as it should be.

The bug as originally described relates to the underlined mnemonics in the 
labels for _A_ttachments (changed to Atta_c_hments in 1.4) and _S_ubject.  In 
each case, Alt+(mnem) should serve to shift focus to the associated field.

Currently, Alt+S is doing exactly what it should (in 1.4b-0513).

Alt+C (for attachments) is a little more problematic, but it does shift the 
focus; the problem is there can be no indication the focus is on the Attachments 
box -- see Bug 205666.

Ideally, there should be an additional hotkey (space? return?) when the focus is 
on the attachments box, that opens the Attach Files dialog; however, this can be 
achieved with Alt-F, F.  This is not currently present.

Wesley George, do you agree that these hotkeys are working?

Comment 5

15 years ago
=>WFM, reporter did not respond.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.