Last Comment Bug 737175 - Make jemalloc build on ICS
: Make jemalloc build on ICS
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Memory Allocator (show other bugs)
: Trunk
: All Gonk (Firefox OS)
: -- normal (vote)
: mozilla14
Assigned To: Michael Wu [:mwu]
:
Mentors:
Depends on:
Blocks: gonk-ics
  Show dependency treegraph
 
Reported: 2012-03-19 13:46 PDT by Michael Wu [:mwu]
Modified: 2012-03-21 03:51 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Avoid name conflict with bionic's stdio.h (3.35 KB, patch)
2012-03-19 13:46 PDT, Michael Wu [:mwu]
khuey: review+
mh+mozilla: review+
Details | Diff | Review

Description Michael Wu [:mwu] 2012-03-19 13:46:13 PDT
Created attachment 607291 [details] [diff] [review]
Avoid name conflict with bionic's stdio.h

This is a patch from an anonymous silicon vendor contributor. It works for me. Other suggestions are welcome - we simply need to avoid a collision with __isthreaded which bionic defines in stdio.h. (why? because bionic)
Comment 1 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2012-03-19 14:19:05 PDT
Comment on attachment 607291 [details] [diff] [review]
Avoid name conflict with bionic's stdio.h

This is fine by me, but I'd like Mike to look at it too (at the least, for a heads up for the porting work he's doing).
Comment 2 Mike Hommey [:glandium] 2012-03-19 15:32:51 PDT
Comment on attachment 607291 [details] [diff] [review]
Avoid name conflict with bionic's stdio.h

Review of attachment 607291 [details] [diff] [review]:
-----------------------------------------------------------------

::: memory/jemalloc/jemalloc.c
@@ +425,4 @@
>  #endif
>  
>  #ifdef MOZ_MEMORY_DARWIN
> +static const bool moz__isthreaded = true;

Just name it 'isthreaded'. It doesn't need to have a special prefixed name. And that's the name used in jemalloc2.
Comment 4 Mounir Lamouri (:mounir) 2012-03-21 03:51:20 PDT
https://hg.mozilla.org/mozilla-central/rev/f163b1d6621e

Note You need to log in before you can comment on or make changes to this bug.