Limit the Question topic to 160 characters

RESOLVED FIXED in 2012.7

Status

P2
normal
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: igarcia, Assigned: rrosario)

Tracking

unspecified
2012.7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=AAQ p=1 [see comment 12])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

7 years ago
[It may need some UX input]

The initial box that users see when trying to ask a question in:
https://support.mozilla.org/en-US/questions/new?product=XXX&category=YY
has a very high limit of characters and this creates and effect where users try to type their whole question there but:
- The box doesn't show the whole text.
- Because of it the actual question is poorly written (I generally feel like they want to fit too much in that box).
- When the bigger box is prompted...they simply copy and paste the question...or they add really few context to the previous question.

My proposal is to limit the size of the box to the actual visible characters or limit it to 140-160 characters (it seems to be an accepted "standard").

The goal of this modification is to improve how the questions are asked.
Whiteboard: [ux-wanted]

Comment 1

7 years ago
Created attachment 607543 [details]
Ask a Question fields

My hypothesis is that, this is happening because our question title field follows what users just entered into the search box.

So, a lot of the times, what we get as questions are really search queries, which may contain a description of the problem. We want summaries instead.

The short-term way to encourage better titles would be to:
* Shorten the text box, like Ibai’s suggestion
* Leave the question title field blank
* Fill in user’s search query into the “Details” field instead

This will encourage user to not only revise what they have written (the “Details” field is big, so they are likely to type more), but also try to rewrite the question title.
(Reporter)

Comment 2

7 years ago
This:
---
So, a lot of the times, what we get as questions are really search queries, which may contain a description of the problem. We want summaries instead.
---

What I actually want to resolve is the opposite.

The problem is that users trigger really long questions but not long enough and then don't re-elaborate their question in the details section. Examples:

https://support.mozilla.org/en-US/questions/923201
https://support.mozilla.org/en-US/questions/923462
https://support.mozilla.org/en-US/questions/923488

Also, and this is based on pure speculation, I presume that more concise titles will bring better search results in the search that is triggered before the question is asked...increasing its efficiency and reducing the amount of repetitive questions.

Comment 3

7 years ago
Created attachment 607920 [details]
Ask a Question fields

Ibai, see if these tweaks could potentially address some of your problems:
* Search query is treated as just that, not pre-filled anywhere
* Instruction is given on the bottom of the field label, vs. small gray text
Attachment #607543 - Attachment is obsolete: true
(Reporter)

Comment 4

7 years ago
Comment on attachment 607920 [details]
Ask a Question fields

With these solution you are creating one additional issue:
- Users need to type their question twice. One for the search and one in the summary. This adds confusion and frustration.

Also, you don't solve the issue of too much verbose in the search query that reduces the effectiveness of the search query.
OS: Mac OS X → All
Hardware: x86 → All

Comment 5

7 years ago
One reason we put the search terms in the title is it made users ask good questions.  They don't put "firefox problem" or "firefox broke" nearly as often as they have an incentive to write something more detailed.
(Reporter)

Comment 6

7 years ago
Several things here:
- We want users to introduce a "Question" in the first screen box. As Cheng says, if they ask a question they will elaborate more and we can serve better results.
- Using this "question" as the "Title" in the second screen will not improve the quality of the "question" if we name it "search query" in the first screen. Because users will populate the box with a "search query" and not a "question".
- Asking users to "Search" in the first screen or phrase their question again will only generate frustration. (i.e. why do I need to search anything here? I want to ask a question...etc)
- Offering almost-unlimited text space for the "Question" triggers way too much verbose that doesn't bring good search results: If you use the title of the first user for a search in the AAQ search you find nothing relevant but if you search for something like "site format is wrong" and similar you can find some helpful threads for this case.
- Offering almost-unlimited text space also offers and opportunity to elaborate more the "Question" but because it's not truly unlimited and the box is a one-line text box the quality is bad, in general. The bad part is that because they put effort on the "Question" users then don't put much effort in the "Description" of the issue as we can see in the second example that I attached above.

So what I'm saying is that we need a way to:
- Get more concrete questions in the first page.
- Get better issue descriptions in the second page.

Limiting the initial box to a "text message" will force users to:
- Be concrete with an small risk of being too concrete (but that risk exists today too).
- Because they can not put almost-everything in the initial box they will be forced to elaborate in an open multi-line box and hopefully they will give us a more detailed description.

I hope that this clarifies where I come from.

Comment 7

7 years ago
(In reply to Ibai from comment #6)
> - Asking users to "Search" in the first screen or phrase their question
> again will only generate frustration.

Yes. That was basically what I was thinking. Rephrasing might lead to better question, but also generate frustration, and people putting something non-descriptive like “Firefox broke”.

So I agree with your idea of limiting the question box to 140 character length. It will help fix part of the problem.

Getting a good question and issue description is a big problem that I still have not solved.

But we can help it by serving better categories, and better search results. You might recall sorting articles into buckets in OptimalSort, like add-ons, accessibility, bookmarks, cookies, crashing, etc. This might be great category candidates for our Ask a question process.

Search results could be made better by giving them tags and better names.
Before we spend a ton more time on this: isn't this whole workflow going away or being completely torn down and rebuilt?
(Reporter)

Comment 9

7 years ago
James, from what I know limiting the box is pretty trivial change.

In other conditions I will agree with you that because the whole AAQ is going to be redesigned we should not invest time on it but:
- The roadmap for it is unclear. The last time somebody mentioned about it was Crystal back in December.
- The feature seem like a quick win.
- We don't know if the new AAQ will disregard everything.
- Even if this is live for 6 months, it seems to be a net win.
- It's a nice "new contributor bug".

That's basically my mental process.
(In reply to Ibai from comment #9)
> James, from what I know limiting the box is pretty trivial change.

Technically, it's not very difficult. Obviously it's not an easy decision, though.

Comment 11

7 years ago
(In reply to James Socol [:jsocol, :james] from comment #8)
> isn’t this whole workflow going
> away or being completely torn down and rebuilt?

You might have heard from Friday’s presentation that part of the AAQ workflow is going to be replaced with a diagnostic triage. We hope that the diagnostic will be enough to solve most people’s problem. But if at some point during the process, the user can select “None of these solves my problem. Ask a question.”

The new AAQ won’t disregard everything, and will contain a page to add a new question. I think that it will benefit from having a generally shorter summary of the problem. Shorter title will also benefit forum search.

Having said this, I think that users still need to be given a pointers to writing good problem summary and description, so contributors can address it faster. These pointers need to be put on the side of the box, and come with an example or two.

For example, on the side of the “Question” field, we can write “Describe your problem in around 10 words. Write the symptoms. Don’t write: “Firefox cannot start”. Do write: “Firefox keeps restarting after installing XYZ toolbar. A good question will help our contributors find a solution for it.”
In either case, it seems like limiting the query/title to 160 characters would be a stop-gap solution for the next 2 month, until we have the new workflow. Bram, if that's in line with what you are thinking, let's just do that for now.

Updated

7 years ago
Target Milestone: --- → 2012.7

Comment 13

7 years ago
Agreed.  Let’s do this for now.

Updated

7 years ago
Whiteboard: [ux-wanted] → u=user c=AAQ p=1

Updated

7 years ago
Whiteboard: u=user c=AAQ p=1 → u=user c=AAQ p=1 [see comment 12]

Updated

7 years ago
Priority: -- → P2
(Assignee)

Updated

7 years ago
Assignee: nobody → rrosario
(Assignee)

Comment 14

7 years ago
Landed (comment 12):

https://github.com/mozilla/kitsune/commit/fa4b2c04b68f346b201e0e0a61d736738aaae560
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Component: Forum → Questions
QA Contact: forum → questions
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.