Replace chromium_base dependencies with Mozilla equivalents in webrtc/signaling code

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: ehugg, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.79 Safari/535.11

Steps to reproduce:

The dependency of webrtc/signaling on chromium_base causes problems when building on Windows since gkmedias is not part of libxul.  We need to replace the chromium_base classes we use with their Mozilla equivalents.  So,
Lock -> Mutex
AutoLock -> MutexAutoLock
PlatformThread -> nsIThread
WaitableEvent -> mozilla::CondVar perhaps

While this is a problem only for the Windows build, this change will be done for all platforms.
(Reporter)

Updated

7 years ago
OS: Linux → All
Hardware: x86_64 → All
(Reporter)

Comment 1

7 years ago
Created attachment 607394 [details] [diff] [review]
Replaced chromium_base locks with Mozilla mutexes
(Reporter)

Comment 2

7 years ago
Created attachment 607611 [details] [diff] [review]
Replaced chromium_base PlatformThread and WaitableEvent calls with PR_Sleep and Monitor
When testing I would be interested to see if the WaitableTimer replacement mozilla::Monitor works first time.  Hopefully it will get initialized in the correct state.  Attempting SIP server registration will tell us if it works.  Everything looks like a really good replacement.
(Reporter)

Comment 4

7 years ago
Created attachment 607993 [details] [diff] [review]
fixed Windows-specific compile issues
(Reporter)

Comment 5

7 years ago
This was fixed a different way.  Patch listed in bug 731421
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.