Stray code on /featured (Featured Reps archive page)

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: stephend, Assigned: giorgos)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 607383 [details]
Screenshot

There's some stray code/markup, on https://reps-dev.allizom.org/featured/:

<input type="hidden" name="assertion" id="id_assertion" />
(Assignee)

Comment 1

7 years ago
Cannot verify this bug, probably a later commit fixed that. 

Thanks for reporting!
(Assignee)

Comment 2

7 years ago
Cannot verify this bug, probably a later commit fixed that. 

Thanks for reporting!
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

7 years ago
Verified WFM; sorry, I meant to close this earlier.
Status: RESOLVED → VERIFIED
Created attachment 611051 [details]
stageScreenshot

Re-opening this bug as it happens whenever you click on the Sign-In button and  the Browser-ID popup isn't shown. See attached screenshot
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 5

7 years ago
Raymond,

Thanks for providing more info. I still cannot reproduce this one though :( What do you mean by "the Browser-ID popup isn't shown"? Does the browserid js get loaded?

Since the <input> field is of type "hidden" shouldn't that be always hidden? Maybe that a crazy ffx bug?
(In reply to Giorgos Logiotatidis [:giorgos] from comment #5)
> Raymond,
> 
> Thanks for providing more info. I still cannot reproduce this one though :(
> What do you mean by "the Browser-ID popup isn't shown"? Does the browserid
> js get loaded?

When I click on the BrowserID sign-in, A pop-up window is shown that enables me to login with BrowserID. This bug happens only when that pop-up window is not shown.
> 
> Since the <input> field is of type "hidden" shouldn't that be always hidden?
> Maybe that a crazy ffx bug?
(Assignee)

Comment 7

7 years ago
Raymond,

Can you think of a reason why the BrowserID pop-up is not shown? Do you have any plugins that prevent it from showing, or any JS blockers that prevent the browserid js from being loaded?

Thanks!
(Reporter)

Comment 8

7 years ago
I'm untargetting this, as it's really hard to reliably reproduce; feels like a race condition, or something.  Also, nobody has complained about it in production, it's even lower priority.
Version: 0.2 - Skon → unspecified
(Assignee)

Updated

7 years ago
Assignee: nobody → giorgos
(Assignee)

Comment 9

7 years ago
I believe that this was related to playdoh's form monkeypatching to mark them safe. We pushed a newer version of playdoh, with changes on the monkeypatching code. I'll leave this open for a month and if nobody manages to reproduce it, I'll mark it as fixed.

Please if you come across this issue, comment on this bug. Thanks!
(Assignee)

Comment 10

7 years ago
Closing this bug after 1 month and a new release.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED

Comment 11

6 years ago
Poked around a bit, still unable to reproduce and no one has reported it occurring again.

Verifying.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.