Closed Bug 737320 Opened 9 years ago Closed 9 years ago

Render standalone images against user-specified background

Categories

(Core :: Layout, enhancement)

11 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 713230

People

(Reporter: gingerbread_man, Unassigned)

Details

This is a follow-up to Bug 376997.

The request is simple: restore previously available functionality by only rendering standalone images against a dark grey background if the status of  browser.display.background_color is default.

(Jared Wein [:jaws])
“The setting Tools > Options > Content > Fonts & Colors > Colors appears to affect all pages on the internet, unless the author of that page has explicitly set a background. I don't think we should be concerned about that setting for when directly-viewed images are displayed.”

Standalone images are not web pages. The site serving them has no say in which background color is used; Firefox shouldn't trample user preferences either.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 713230
Masatoshi: How is “Render standalone images against user-specified background” a duplicate of “Transparent images should be rendered against the default background color.”
If you read that bug, that option was discussed there and rejected.
Robert: Thanks. That is information I expect to be added here instead of resolving without any explanatory comment.
(In reply to Robert Longson from comment #3)
> If you read that bug, that option was discussed there and rejected.

“If you had read all 50 comments of what is an unrelated bug, you'd know your idea was previously discussed somewhere in there and rejected for no reason.”

Great, thanks a lot.
(In reply to Robert Longson from comment #3)
> If you read that bug, that option was discussed there and rejected.

Specifically, it looks like the suggestion was raised by Daniel Glazman in bug 713230 comment 24, and rejected by Justin Dolske in bug 713230 comment 34 (Glazman capitulated in bug 713230 comment 40).
You need to log in before you can comment on or make changes to this bug.