Closed Bug 737439 Opened 10 years ago Closed 10 years ago

Sync occasionally spins the CPU, making interaction very slow and the phone hot

Categories

(Firefox for Android Graveyard :: Android Sync, defect, P2)

ARM
Android
defect

Tracking

(blocking-fennec1.0 +, fennec14+)

RESOLVED DUPLICATE of bug 722379
Tracking Status
blocking-fennec1.0 --- +
fennec 14+ ---

People

(Reporter: joe, Assigned: joe)

References

()

Details

(Whiteboard: sync)

I haven't been able to find STR on this, but I regularly find that Fennec spins my phone (Galaxy Nexus)'s CPU, making interaction (panning and zooming) very slow - think 1-2 fps - and my phone gradually gets hot.

This is a fairly content-free bug, but I want it on file because it's a very bad problem when it happens.
If it matters, I'm using Sync.
I have now had this happen twice on this CNN URL. Let the page load fully, including the comments.
When I'm seeing this, I get a stream of things like

D/BrowserRepoSession( 6638): Adding visits for GUID IIWPucBeSlE7
D/BrowserDataAccessor( 6638): Storing visits for IIWPucBeSlE7, replacing IIWPucBeSlE7
D/BrowserRepoSession( 6638): Adding visits for GUID Iea3p_lb1RGT
D/BrowserDataAccessor( 6638): Storing visits for Iea3p_lb1RGT, replacing Iea3p_lb1RGT

After a little while on this site, the problem seems to go away.

I choose Ally!
blocking-fennec1.0: --- → ?
Summary: Fennec occasionally spins the CPU, making interaction very slow and the phone hot → Sync occasionally spins the CPU, making interaction very slow and the phone hot
OS: Mac OS X → Android
Hardware: x86 → ARM
Whiteboard: sync
Yup, it's syncing. I expect you're adding a lot of history on desktop, so it's doing non-trivial work when it syncs on the phone. The particular site shouldn't matter; Sync will run even when Fennec is not, so you're probably just noticing more in this case.

If you get a chance, logcat with time output captured during or after a slow period would help:

http://160.twinql.com/how-to-file-a-good-android-sync-bug

Thanks!
Component: General → Android Sync
Product: Fennec Native → Mozilla Services
QA Contact: general → android-sync
Version: Trunk → unspecified
tracking-fennec: --- → 14+
blocking-fennec1.0: ? → +
Priority: -- → P2
assigning to joe (and mfinkle) for gathering more information
Assignee: nobody → joe
I had this sync happen while I was using Fennec: http://pastebin.mozilla.org/1528382

I then forced a sync at Richard's request: http://pastebin.mozilla.org/1528333

Are these of any help?
See Also: → 713939
Duplicate of this bug: 737879
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 722379
Product: Mozilla Services → Android Background Services
Product: Android Background Services → Firefox for Android
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.