Last Comment Bug 737454 - Intermittent test_bug518777.html | Test timed out
: Intermittent test_bug518777.html | Test timed out
Status: RESOLVED FIXED
: intermittent-failure, regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: mozilla14
Assigned To: Serge Gautherie (:sgautherie)
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on: 735805
Blocks: 438871 518777
  Show dependency treegraph
 
Reported: 2012-03-20 08:53 PDT by Matt Brubeck (:mbrubeck)
Modified: 2012-11-25 19:31 PST (History)
3 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wontfix
wontfix
fixed


Attachments
(Av1) test_bug518777.html: Move code from body to head, Rewrite it a little [Checked in: Comment 10] (3.08 KB, patch)
2012-03-20 17:00 PDT, Serge Gautherie (:sgautherie)
roc: review+
lukasblakk+bugs: approval‑mozilla‑aurora-
lukasblakk+bugs: approval‑mozilla‑beta-
Details | Diff | Review
(Bv1-ab) test_bug518777.html: Fix execution order, Rewrite it a little [Checkin: Comment 19] (3.03 KB, patch)
2012-03-27 02:50 PDT, Serge Gautherie (:sgautherie)
no flags Details | Diff | Review

Description Matt Brubeck (:mbrubeck) 2012-03-20 08:53:04 PDT
The screenshot shows the test harness with "Status: Fail, Passed: 2504, Failed: 1, Todo: 8, currently executing: test_bug569520.html", and "Mozilla Bug 569520" in the test iframe.

https://tbpl.mozilla.org/php/getParsedLog.php?id=10209783&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitests-4/5 on 2012-03-20 05:01:47 PDT for push 60dd3e5fe989

builder: mozilla-inbound_xp_test-mochitests-4
slave: talos-r3-xp-072
starttime: 1332244907.14
results: warnings (1)
buildid: 20120320034240
builduid: 04f1db1e018742bf9cda6d431bad1fad
revision: 60dd3e5fe989

2766 INFO TEST-START | /tests/layout/base/tests/test_bug514127.html
2767 INFO TEST-PASS | /tests/layout/base/tests/test_bug514127.html | all pixels blue
2768 INFO TEST-END | /tests/layout/base/tests/test_bug514127.html | finished in 51ms
2769 INFO TEST-START | /tests/layout/base/tests/test_bug518777.html
2770 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/base/tests/test_bug518777.html | Test timed out.
args: ['C:\\talos-slave\\test\\build\\bin\\screenshot.exe', 'c:\\docume~1\\cltbld\\locals~1\\temp\\mozilla-test-fail_ny2p16']

2771 INFO TEST-END | /tests/layout/base/tests/test_bug518777.html | finished in 303489ms
Comment 1 Treeherder Robot 2012-03-20 09:53:13 PDT
dholbert
https://tbpl.mozilla.org/php/getParsedLog.php?id=10215049&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitests-4/5 on 2012-03-20 09:26:18

2770 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/base/tests/test_bug518777.html | Test timed out.
Comment 2 Treeherder Robot 2012-03-20 10:39:25 PDT
mbrubeck
https://tbpl.mozilla.org/php/getParsedLog.php?id=10215717&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound debug test mochitests-4/5 on 2012-03-20 09:57:37

2770 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/base/tests/test_bug518777.html | Test timed out.
Comment 3 Treeherder Robot 2012-03-20 12:35:10 PDT
mbrubeck
https://tbpl.mozilla.org/php/getParsedLog.php?id=10218597&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitests-4/5 on 2012-03-20 12:04:34

2770 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/base/tests/test_bug518777.html | Test timed out.
Comment 4 Treeherder Robot 2012-03-20 13:14:27 PDT
mbrubeck
https://tbpl.mozilla.org/php/getParsedLog.php?id=10219851&tree=Firefox
Rev3 WINNT 5.1 mozilla-central opt test mochitests-4/5 on 2012-03-20 12:48:52

2770 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/base/tests/test_bug518777.html | Test timed out.
Comment 5 Treeherder Robot 2012-03-20 14:58:39 PDT
mbrubeck
https://tbpl.mozilla.org/php/getParsedLog.php?id=10222732&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitests-4/5 on 2012-03-20 14:30:57

2770 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/base/tests/test_bug518777.html | Test timed out.
Comment 6 Serge Gautherie (:sgautherie) 2012-03-20 15:39:38 PDT
(In reply to TinderboxPushlog Robot from comment #4)
> https://tbpl.mozilla.org/php/getParsedLog.php?id=10219851&tree=Firefox

{
2769 INFO TEST-START | /tests/layout/base/tests/test_bug518777.html
2770 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/base/tests/test_bug518777.html | Test timed out.
SCREENSHOT: data:image/png;base64,[ executing test_bug548545.xhtml ]
2771 INFO TEST-END | /tests/layout/base/tests/test_bug518777.html | finished in 302833ms
}

In bug 735805, I fixed (only) the main page going away too soon.
What remains to be fixed would be the iframe executing too soon.
Comment 7 Serge Gautherie (:sgautherie) 2012-03-20 17:00:55 PDT
Created attachment 607778 [details] [diff] [review]
(Av1) test_bug518777.html: Move code from body to head, Rewrite it a little
[Checked in: Comment 10]
Comment 8 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-03-20 17:49:25 PDT
Comment on attachment 607778 [details] [diff] [review]
(Av1) test_bug518777.html: Move code from body to head, Rewrite it a little
[Checked in: Comment 10]

Review of attachment 607778 [details] [diff] [review]:
-----------------------------------------------------------------

I guess the iframe sometimes finishes loading before the script has been parsed. Good catch!
Comment 9 Treeherder Robot 2012-03-20 18:41:38 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=10228072&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitests-4/5 on 2012-03-20 18:09:00

2783 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/base/tests/test_bug518777.html | Test timed out.
Comment 10 Serge Gautherie (:sgautherie) 2012-03-20 20:37:28 PDT
Comment on attachment 607778 [details] [diff] [review]
(Av1) test_bug518777.html: Move code from body to head, Rewrite it a little
[Checked in: Comment 10]

https://hg.mozilla.org/mozilla-central/rev/f374738260ff


[Approval Request Comment]
Regression caused by (bug #): Bug 518777.
User impact if declined: None, but this would help to prevent random-oranges.
Testing completed (on m-c, etc.): This comment.
Risk to taking this patch (and alternatives if risky): None, test-only.
String changes made by this patch: None.
Comment 11 Justin Dolske [:Dolske] 2012-03-20 21:25:33 PDT
Serge: why did you just cancel a bunch of builds for this push on the mozilla-central tree?
Comment 12 Serge Gautherie (:sgautherie) 2012-03-20 21:53:11 PDT
(In reply to Justin Dolske [:Dolske] from comment #11)
> Serge: why did you just cancel a bunch of builds for this push on the
> mozilla-central tree?

These builds are unaffected by this changeset.
That was my first time use of the feature: I got the feeling I wanted then stoppped.
Comment 13 Matt Brubeck (:mbrubeck) 2012-03-20 22:15:54 PDT
Just FYI, cancelling build jobs can leave the objdir in a bad state and cause later builds to fail.  The cancel button should be used only for test jobs (except on Try, where every build clobbers automatically).

Ideally TBPL should hide the button for build jobs on non-Try trees; I think there's an open bug about that somewhere...
Comment 14 Treeherder Robot 2012-03-21 08:46:14 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=10236772&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitests-4/5 on 2012-03-21 03:26:31

2770 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/base/tests/test_bug518777.html | Test timed out.
Comment 15 Treeherder Robot 2012-03-21 15:31:33 PDT
mak77%bonardo.net
https://tbpl.mozilla.org/php/getParsedLog.php?id=10251159&tree=Fx-Team
Rev3 WINNT 5.1 fx-team pgo test mochitests-4/5 on 2012-03-21 13:03:10

2770 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/base/tests/test_bug518777.html | Test timed out.
Comment 16 Lukas Blakk [:lsblakk] use ?needinfo 2012-03-21 16:43:58 PDT
Comment on attachment 607778 [details] [diff] [review]
(Av1) test_bug518777.html: Move code from body to head, Rewrite it a little
[Checked in: Comment 10]

[Triage Comment]
If this isn't going to impact the user I see no reason not to let it ride the trains.
Comment 17 Serge Gautherie (:sgautherie) 2012-03-22 00:01:12 PDT
(In reply to TinderboxPushlog Robot from comment #14)
> https://tbpl.mozilla.org/php/getParsedLog.php?id=10236772&tree=Mozilla-
> Inbound
> Rev3 WINNT 5.1 mozilla-inbound opt test mochitests-4/5 on 2012-03-21 03:26:31

Didn't yet have this fix:
https://hg.mozilla.org/integration/mozilla-inbound/rev/537c3637b992
89893:537c3637b992
https://hg.mozilla.org/integration/mozilla-inbound/rev/f374738260ff
89896:f374738260ff


(In reply to TinderboxPushlog Robot from comment #15)
> https://tbpl.mozilla.org/php/getParsedLog.php?id=10251159&tree=Fx-Team
> Rev3 WINNT 5.1 fx-team pgo test mochitests-4/5 on 2012-03-21 13:03:10

Didn't yet have this fix:
https://hg.mozilla.org/integration/fx-team/rev/e4901b5d891a
89738:e4901b5d891a
https://hg.mozilla.org/integration/fx-team/rev/f374738260ff
89824:f374738260ff
Comment 18 Serge Gautherie (:sgautherie) 2012-03-27 02:50:58 PDT
Created attachment 609666 [details] [diff] [review]
(Bv1-ab) test_bug518777.html: Fix execution order, Rewrite it a little [Checkin: Comment 19]

Bv1-ab = bug 735805 patch AAv1 + this bug patch Av1,
with
(In reply to Alex Keybl [:akeybl] from bug 735805 comment #77)
> (the above includes blanket approval for the other test fixes for Aurora 13)

NB: Applies cleanly to Beta/12 too.

***

(In reply to Lukas Blakk [:lsblakk] away from bugmail until March 31st from comment #16)
> If this isn't going to impact the user I see no reason not to let it ride
> the trains.

"Overruled", to be able to land bug 735805. Less random oranges helps "developers".
Comment 19 Jens Hatlak (:InvisibleSmiley) 2012-03-31 06:03:26 PDT
Comment on attachment 609666 [details] [diff] [review]
(Bv1-ab) test_bug518777.html: Fix execution order, Rewrite it a little [Checkin: Comment 19]

http://hg.mozilla.org/releases/mozilla-aurora/rev/6c2316525c7c

Note You need to log in before you can comment on or make changes to this bug.