If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash Reports not appearing in Socorro

RESOLVED INVALID

Status

Socorro
General
RESOLVED INVALID
6 years ago
a year ago

People

(Reporter: bc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
08:50 <        bc> hey, i've just submitted several crash reports on mac/windows with today's nightly and it appears they haven't been received. Known issue?
08:51 <@     laura> bc: how do you know they haven't been received?
08:51 <@     laura> (no, it's not a known issue)
08:51 <        bc> ok. i'll file a bug.
08:52 <        bc> anyway for me to tell if this is in the client or in the receiver?
08:52 <@     laura> yes
08:52 <@     laura> so what behavior do you see?
08:52 <@     laura> bc: ?
08:53 <        bc> i crash then submit the crash report. but when i go to about:crashes and try to load the crash report i see crash not found
08:53 <        bc> url to reproduce with today's nightly is http://www.dhl.com/en/express/shipping/get_rate_and_time_quote.html
08:53 <        bc> sample bp ids in https://bugzilla.mozilla.org/show_bug.cgi?id=737447
08:53 <   firebot> Bug 737447 cri, --, ---, general, NEW, Assertion failure: v.isBoolean(),
08:54 <@     laura> looking
08:55 <        bc> fwiw, i kept reloading the page which normally fixes any not found issues for me but it didn't work for me this time.
08:55 <@     laura> yeah, I don't think we're backlogged but I'll check
08:56 <@     laura> nope https://crash-stats.mozilla.com/status
08:56 <    lonnen> oldest in the queue is about a minute
08:56 <        bc> yeah. i checked that. all green.
08:56 <@     laura> you could see if the crashes are still on your disk
08:57 <        bc> well, apart from ns being a little orange
08:57 <        bc> ok.
08:58 <@     laura> bc: in about crashes, are they showing up with a bp- in front of them?
08:58 <        bc> yes
08:59 <@     laura> ok, so that should mean they have been submitted
08:59 <@     laura> that's really odd
08:59 <        bc> they show up in submitted
08:59 <@     laura> where?
08:59 <        bc> ~/Library/Application Support/Firefox/Crash Reports/submitted 
08:59 <        bc> on my mac.
08:59 <@     laura> ok
08:59 <@     laura> huh
08:59 <        bc> but i see the same behavior on windows
08:59 <        bc> can you reproduce the crash and try to submit?
09:00 <@     laura> good idea, will do
09:00 <@     laura> (have to download nightly first, I run aurora)
09:00 <        bc> heh
09:00 <@     laura> lonnen: do you have nightly handy?
09:00 <   peterbe> rhelmer: do you prefer Skype or an extension number?
09:00 <    lonnen> I'm running it all the time
09:00 <@     laura> lonnen: try that url then?
09:00 <        bc> lonnen rocks
09:00 <    lonnen> yes'm
09:00 <@     laura> lonnen:  http://www.dhl.com/en/express/shipping/get_rate_and_time_quote.html
09:00 <@     laura> bc: sorry :)
09:00 <        bc> np.
09:02 <        bc> ah. i was thinking you meant status.mozilla.org but crash-stats status is way better. :-)
09:02 <    lonnen> it takes a while but it loads
09:02 <    lonnen> well, a page loads. I get redirected.
09:02 <@     laura> bc: I'll go see if I can find it in the collector logs
09:03 <@     laura> see if it caused an error or something
09:03 <        bc> laura: is the zero crashes for today on https://crash-stats.mozilla.com/products/Firefox related?
09:03 <@     laura> bc: double check for me that the crash files are not zero length
09:03 <        bc> the bp-*.txt ?
09:03 <@     laura> bc: no, that's because metrics failed to push ADUs overnight
09:03 <    lonnen> also, apparently haven't updated nightly in 6 days
09:03 <@     laura> they are working on it
09:03 <@     laura> bc: yeah
09:03 <    lonnen> lemme get this updated, try again
09:03 <        bc> it had the crash id in it 
09:03 <@     laura> oh nm
09:03 <@     laura> sorry
09:03 <        bc> lonnen: i think this was a recent regrssion.
09:03 <    lonnen> bc: yep, applying a flurry of patches
09:04 <@     laura> bc you should probably file a bug against Socorro so we can log this conversation
09:04 <        bc> ok.
I think this bug has outdated itself. Our processing, in particular the priority jobs, are working just fine now. 
Once we discover future problems we'll have to open a new fresh specific bug.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.