Last Comment Bug 737464 - Add frame and iframe globals to the debugger when present in a page
: Add frame and iframe globals to the debugger when present in a page
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: Firefox 14
Assigned To: Panos Astithas [:past] (away until 7/21)
:
Mentors:
Depends on:
Blocks: minotaur
  Show dependency treegraph
 
Reported: 2012-03-20 09:12 PDT by Panos Astithas [:past] (away until 7/21)
Modified: 2012-03-30 02:00 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
WIP (1.38 KB, patch)
2012-03-23 05:52 PDT, Panos Astithas [:past] (away until 7/21)
no flags Details | Diff | Splinter Review
Working patch (5.45 KB, patch)
2012-03-27 09:57 PDT, Panos Astithas [:past] (away until 7/21)
rcampbell: review+
Details | Diff | Splinter Review

Description Panos Astithas [:past] (away until 7/21) 2012-03-20 09:12:33 PDT
Properly debugging a page with frames or iframes requires adding their globals to the debugger instance.
Comment 1 Panos Astithas [:past] (away until 7/21) 2012-03-23 05:52:13 PDT
Created attachment 608672 [details] [diff] [review]
WIP

Store this for now in case my laptop blows up or something.
Comment 2 Panos Astithas [:past] (away until 7/21) 2012-03-27 09:57:45 PDT
Created attachment 609763 [details] [diff] [review]
Working patch

This appears to work well in my testing.
Comment 3 Rob Campbell [:rc] (:robcee) 2012-03-27 12:51:19 PDT
Comment on attachment 609763 [details] [diff] [review]
Working patch

only thing I'd advise for your test is if you could wrap the entire thing inside an outer test function, that should prevent gPane and gTab from leaking.
Comment 4 Panos Astithas [:past] (away until 7/21) 2012-03-28 02:28:37 PDT
(In reply to Rob Campbell [:rc] (:robcee) from comment #3)
> Comment on attachment 609763 [details] [diff] [review]
> Working patch
> 
> only thing I'd advise for your test is if you could wrap the entire thing
> inside an outer test function, that should prevent gPane and gTab from
> leaking.

Good idea, will do.
Comment 5 Panos Astithas [:past] (away until 7/21) 2012-03-28 04:16:54 PDT
https://hg.mozilla.org/integration/fx-team/rev/0b6a274e8b5a
Comment 6 Panos Astithas [:past] (away until 7/21) 2012-03-28 08:30:02 PDT
Backed out due to new randomorange:

https://hg.mozilla.org/integration/fx-team/rev/3faec66b9413
Comment 7 Tim Taubert [:ttaubert] 2012-03-29 02:57:17 PDT
https://hg.mozilla.org/mozilla-central/rev/5759f9c0d1eb
Comment 8 Panos Astithas [:past] (away until 7/21) 2012-03-29 03:20:46 PDT
I had forgotten to note that I relanded this, since it wasn't the one triggering the oranges:

https://hg.mozilla.org/integration/fx-team/rev/5759f9c0d1eb

Note You need to log in before you can comment on or make changes to this bug.