remove unused frontend logic and flags

RESOLVED FIXED in mozilla14

Status

()

Core
JavaScript Engine
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: luke, Unassigned)

Tracking

unspecified
mozilla14
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 607642 [details] [diff] [review]
rm

It turns out that there is even more dead code to be removed after bug 730497; some 400 lines of it.  The patch also removes several TCF_FUN_* flags and thus takes the opportunity to turn TCF_FUN_* into an enum and reformat things so that they look pretty.

This patch removes code that jimb rewrote for bug 501908.  Jim: I naively tried to remove CleanFunctionList, but SetFunctionKinds seems to depend on it.  Perhaps in a later patch CleanFunctionList could be simplified, though?
Attachment #607642 - Flags: review?(jimb)
Review ping.  Green on try.

Comment 2

6 years ago
Comment on attachment 607642 [details] [diff] [review]
rm

Review of attachment 607642 [details] [diff] [review]:
-----------------------------------------------------------------

Wow, that's wonderful.
- TCF_FUN_MODULE_PATTERN: completely unused
- TCF_FUN_ENTRAINS_SCOPES: completely unused
- TCF_FUN_SETS_OUTER_NAME: only "used" to set itself
- PND_FUNARG: only used to compute TCF_FUN_USES_OWN_NAME; instead, set that pessimistically

I assume you've checked that this doesn't affect our performance, and might improve our front-end performance.
Attachment #607642 - Flags: review?(jimb) → review+
I haven't measured speedup, let's see if anything pops out of talos.  With bug 725161, TCF_FUN_USES_OWN_NAME should be removed which should avoid any possibility of slowdown from this patch.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

3 years ago
Duplicate of this bug: 558903
You need to log in before you can comment on or make changes to this bug.