If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Deleting Numerous messages from Trash is very slow.

VERIFIED DUPLICATE of bug 66576

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 66576
17 years ago
13 years ago

People

(Reporter: kwasnicki, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When I select numerous messages in my Trash folder, ie: 20+, and select delete
it takes about 1 seconds/message to delete each message. If I select fewer than
10 messages the delete is almost instantaneous.

Updated

17 years ago
QA Contact: esther → sheelar
Can you please give us your build ID, flavor of Linux, machine hardware, and
whether you're using POP3/IMAP and what your delete model is, thanks!
(Reporter)

Comment 2

17 years ago
>Can you please give us your build ID, flavor of Linux, machine hardware, and
>whether you're using POP3/IMAP and what your delete model is, thanks!

Build ID: 2001032614
Platform: Red Hat Linux, v6.0, kernel 2.2.12
CPU: Intel P2 400Mghz, 192 Mb Ram

POP3
Delete model??? Um, select a 100 messages in trash folder, press delete, and
wait for two-three mintues.

Comment 3

17 years ago
commercial Build ID: 2001041105
Platform: Red Hat Linux, v6.2, GNU 4.5
CPU: Intel P3 700Mghz
I deleted about 200 messages from my pop3 trash and the deletion was done in 
about a second or even less.  I did not have to wait for 3 minutes.  worksforme.
Can you try this on a recent build and see if it still happens. 
I see this too on winnt.  worse on linux.  I just tried to delete about 1000
messages from my trash.

I'll check if we are batching all that we can with deletes.


Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 5

16 years ago
Delete speed has improved with outliner and various db fixes.
Resolving as duplicate of bug 66576.

*** This bug has been marked as a duplicate of 66576 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.