IonMonkey: Assertion failure: iter->getOffset() > perforation.getOffset(), at ../ion/shared/IonAssemblerBufferWithConstantPools.h:630

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
major
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: decoder, Unassigned)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Other Branch
ARM
Linux
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
The following testcase asserts on ionmonkey revision e96d5b1f47b8 (run with --ion -n -m --ion-eager):


function reportCompare (expected, actual, description) {}
var summary = 'Math.random should be random';
var actual = '';
var expect = 'between 47.5% and 52.5%';
if (odd1 >= 0  && odd1 <= 52.5) {
  actual = ' is ' + odd1.toFixed(3);
}
reportCompare(expect, actual, summary);
if (odd2 >= 47.5 && odd2 <= 52.5) {}
(Reporter)

Comment 1

6 years ago
ARM only, Ccing mjrosenb.
(Reporter)

Comment 2

6 years ago
This doesn't reproduce for me anymore. I'll be hard to bisect since it's ARM only. 

Martin, do you know if this is really fixed?
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.