If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Links containing paragraph tags don't show up as links

VERIFIED DUPLICATE of bug 6654

Status

()

Core
HTML: Parser
P3
normal
VERIFIED DUPLICATE of bug 6654
19 years ago
19 years ago

People

(Reporter: pavlos, Assigned: rickg)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
This probably an HTML parser bug/feature. It appears on both M5 and M6,
invoked as either "viewer" or "apprunner". I use Debian GNU/Linux, libc6.

If there is a <P> tag between <A HREF=...> and <\A> then the link shows
up as normal text and not as a link.

I do not know if this is valid HTML but it works with Navigator 4.51.
I encountered it in the El Pais website (http://www.elpais.es) which
uses it to mark its headlines as links. With M6 the headlines fail
to show as links (M5 crashes).

To reproduce, view the page. Here is minimal source.

<HTML>
<HEAD>
</HEAD>
<BODY>

<A HREF="foo">   control</A><P>
<A HREF="foo"><P>error  </A><P>

</BODY>
</HTML>

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 1

19 years ago
*** This bug has been marked as a duplicate of 6654 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 2

19 years ago
This is in fact terrifically awful HTML. However, it now works in 5.x for
compatibility reasons.
You need to log in before you can comment on or make changes to this bug.