Last Comment Bug 737707 - Cannot play videos in BrightCove SmartPlayer on studio1290.com, site should upgrade to new Brightcove Player
: Cannot play videos in BrightCove SmartPlayer on studio1290.com, site should u...
Status: RESOLVED WORKSFORME
[gecko] [topapps] [website-compatibil...
:
Product: Tech Evangelism
Classification: Other
Component: Mobile (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://studio1290.com/
: 751705 (view as bug list)
Depends on: brightcove
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 17:28 PDT by Jason Smith [:jsmith]
Modified: 2016-05-20 13:53 PDT (History)
22 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
-
unaffected
-
-


Attachments
Unable to Play Video Fennec Native (138.93 KB, image/png)
2012-03-20 17:28 PDT, Jason Smith [:jsmith]
no flags Details
testcase (382 bytes, text/html)
2012-04-12 09:41 PDT, Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( )
no flags Details
testcase2 (450 bytes, text/html)
2012-04-12 09:44 PDT, Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( )
no flags Details

Description Jason Smith [:jsmith] 2012-03-20 17:28:34 PDT
Created attachment 607786 [details]
Unable to Play Video Fennec Native

Steps:

1. Go to http://studio1290.com/
2. Select an artist

Expected:

The video should be able to be played in the browser. This is possible to do on the stock browser.

Actual:

An error is reported indicating that the video is unsupported in the browser (fennec native).

Additional Notes:

This is not a user-agent sniffing problem, as changing the user agent does not change the layout of the website, the video playing, etc. According to Kevin, sounds like this is an issue about support for video type that the stock browser supports, but not fennec native.
Comment 1 Aaron Train [:aaronmt] 2012-03-21 07:39:52 PDT
Jason,

That error message indicates that there was a problem playing the video at the time, not that it is unsupported.

Visiting one of the artist's music videos (e.g., http://studio1290.com/emphatic-put-down-the-drink-studio1290/) reveals a flash embedded video.

I see the plugin container with the "Tap to Play" canvas, but tapping appears to not initialize the player or draw the player. This sounds more like a plugin-container issue maybe?

CC'ing :snorp
Comment 2 Aaron Train [:aaronmt] 2012-04-11 07:37:47 PDT
I can still reproduce this as of 04/11.
Comment 3 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-04-11 15:18:13 PDT
This is basically a saved page from desktop Firefox (with js turned off):
http://people.mozilla.org/~mwargers/tests/unminimized/Studio1290.htm
That one is working fine in Fennec Native and Fennec XUL.

The http://studio1290.com/ site doesn't work in Fennec Native and Fennec XUL, though. In Fennec Native, I see only a black box, it seems. In Fennec XUL, I see the unsupported video content.

With using the DOM Inspector used in Fennec XUL on desktop, I noticed that this 'unsupported video content' thing is an iframe pointing to this url:
http://c.brightcove.com/services/viewer/htmlFederated?&width=640&height=360&flashID=myExperience1182716547001&bgcolor=%23FFFFFF&playerID=700049358001&playerKey=AQ~~%2CAAAAAAQyLFU~%2C54jA5x37P575puIrJBUOyAIVyZPy272t&isVid=true&isUI=true&dynamicStreaming=true&%40videoPlayer=1182716547001&autoStart=&debuggerID=&showNoContentMessage=&startTime=1334182463373&refURL=not available
Comment 4 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-04-11 16:01:29 PDT
That was with the Android Nexus One UAgent string with Fennec XUL on Desktop.
With the default, I get an update Flash message.

At this point, I'm not sure what is going on at that site.
Comment 5 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-04-11 16:10:50 PDT
Oh wait, I've included the styling now in my unminimized testcase and now I can reproduce the issue in Fennec Native, while it works in desktop Firefox.
So it looks like there is some kind of CSS that is causing Fennec Native to not show the Flash object, while it works in desktop Firefox.

I guess it might be some gfx issue then. I'll try to narrow it down tomorrow.
Comment 6 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-04-12 09:41:10 PDT
Created attachment 614412 [details]
testcase

I haven't been able to get a minimized testcase, but I think the problem that I describe here is basically the same issue:
- Make sure you have at least 2 tabs open, one with this testcase
- Open the testcase
- Open the tab list popup and tap on the tab with the testcase (so you don't really switch tabs)

Expected result:
- Flash circle stays visible

Actual result:
- Flash circle disappears

Tested on the Samsung Galaxy Nexus.
Comment 7 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-04-12 09:44:12 PDT
Created attachment 614413 [details]
testcase2

In this case, you shouldn't see the Flash circle anymore after 500ms.
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2012-04-12 11:58:57 PDT
Margaret - Can you dig a bit into this issue?
Comment 9 :Margaret Leibovic 2012-04-16 13:43:18 PDT
(In reply to Aaron Train [:aaronmt] from comment #1)

> I see the plugin container with the "Tap to Play" canvas, but tapping
> appears to not initialize the player or draw the player. This sounds more
> like a plugin-container issue maybe?

This sounds like bug 745016.

With plugins enabled by default, I am still seeing only blackness where there should be a video (both at http://studio1290.com/emphatic-put-down-the-drink-studio1290/ and at http://people.mozilla.org/~mwargers/tests/unminimized/Studio1290.htm). I agree with Martijn that this sounds like some sort of gfx/flash bug.
Comment 10 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-04-16 13:49:34 PDT
Mine.
Comment 11 Mark Finkle (:mfinkle) (use needinfo?) 2012-04-16 14:09:12 PDT
What blocking assessment is there for this bug?
Comment 12 Johnathan Nightingale [:johnath] 2012-04-17 12:30:51 PDT
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #10)
> Mine.

That sounds like a person with an opinion about whether this should block (or maybe dup to bug 745016?)
Comment 13 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-04-18 07:01:12 PDT
This has nothing to do with bug 745016.
Comment 14 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-04-18 07:05:14 PDT
Yeah, it doesn't appear to be related to bug 745016.
Comment 15 Johnathan Nightingale [:johnath] 2012-04-18 12:37:14 PDT
Marking this a release blocker, at least until we have a clearer understanding of how widespread the problem is likely to be. WDYT, snorp?
Comment 16 Jason Smith [:jsmith] 2012-04-18 16:34:29 PDT
Some notes from recent email threads:

- This is a tier 1 application for web apps (also a tier 1 partner)
- The application is pretty much useless without the video issue being fixed on gecko
- Stock browser behavior as of 4/18 still allows the video to play
- Fennec native behavior as of 4/18 still does not allow the video to play
- We do have a contact from Ron to contact the partner directly about this site if we think there's value to contacting them

Open question:

- Is there value to contacting the partner about this to get more information about the underlying issue?
Comment 17 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-04-19 13:03:15 PDT
(In reply to Johnathan Nightingale [:johnath] from comment #15)
> Marking this a release blocker, at least until we have a clearer
> understanding of how widespread the problem is likely to be. WDYT, snorp?

It looks like the plugin gets initialized, but for some reason never gets painted. Won't know more until I look deeper.
Comment 18 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-04-27 12:50:31 PDT
I looked at this some more and the plugin is initialized, but nsPluginInstanceOwner::Paint never gets called for some reason. I think we need a layout or maybe gfx person to take a look.
Comment 19 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-04-27 13:37:27 PDT
jet, roc: See above, we need some layout/gfx help on tracking this down
Comment 20 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-04-27 15:08:15 PDT
A reduced testcase is probably the best first step here
Comment 21 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-04-27 15:25:40 PDT
Robert, can you reproduce the issue in comment 6?
Comment 22 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-04-28 18:46:38 PDT
(Sorry, I didn't read your earlier comments carefully enough.)

Actually Flash doesn't seem to work in Nightly on my phone at all.
Comment 23 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-04-28 18:57:16 PDT
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #22)
> (Sorry, I didn't read your earlier comments carefully enough.)
> 
> Actually Flash doesn't seem to work in Nightly on my phone at all.

What's the symptom? Crashes? Doesn't display? Says it's not installed?

What phone is it? What version of Android?
Comment 24 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-04-28 22:33:05 PDT
Turns out it's only because I'm an idiot --- I had assumed Flash was preinstalled, but it wasn't.

Now I see the problem described in comment #6.

I notice this is a windowed plugin. That probably means the problem is to do with the way we configure the plugin's Android surface, not nsPluginInstanceOwner::Paint.
Comment 25 Jet Villegas (:jet) 2012-05-01 12:36:50 PDT
Assigning to self to get more info re: the plugin's Android surface.
Comment 26 Asa Dotzler [:asa] 2012-05-01 12:38:00 PDT
marking as blocking k9o for tier 1 app compat.
Comment 27 Brad Lassey [:blassey] (use needinfo?) 2012-05-01 12:47:36 PDT
Not blocking the release because studio1290.com is the only site we've heard of with this issue. If more sites crop up during the beta cycle, please re-nom.
Comment 28 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-05-01 15:17:11 PDT
I suspect this is also the cause of bug 745152.
Comment 29 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-05-02 06:35:04 PDT
Also seeing this on http://www.telegraaf.nl/binnenland/12040352/__Juwelierkillers_gevlucht_naar_Belgi__.html
Comment 30 Jet Villegas (:jet) 2012-05-02 11:32:51 PDT
Appears to be videos served by the Brightcove CDN. Their playback code handles the Flash/HTML5 video switching. I'll need to poke around this some more to see if we're actually getting a Flash SWF here, or are choking on H.264 <video>

Also reaching out to contacts at BrightCove. This is a very popular CDN and raises the priority on this bug.
Comment 31 Jet Villegas (:jet) 2012-05-02 15:27:04 PDT
I posted a reduced test case:
http://junglecode.com/sites/737707.html

Additional info from BrightCove:

We can't technically support this browser, but if you are getting errors, if you can show them to me I might be able to give you a clue what's going on. The videos are playing for me on my Android in Dolphin.
 
I have also found issues with some videos on some devices due to codecs. The noted video has two possible renditions, may want to confirm if both play on the device outside our player.

http://brightcove.vo.llnwd.net/d17/unsecured/media/70397013/70397013_1183199105001_Emphatic---Put-Down-The-Drink.mp4

http://brightcove.vo.llnwd.net/d17/unsecured/media/70397013/70397013_1183199106001_Emphatic---Put-Down-The-Drink.mp4
Comment 32 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-05-02 17:03:50 PDT
We should fix the simple Flash testcase in comment #6 and hope it fixes this.
Comment 33 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-05-02 17:09:01 PDT
I agree.
Fwiw, I tried getting a minimized testcase out of the site.
WIP here: http://people.mozilla.org/~mwargers/tests/unminimized/Studio1290.htm
But the site had a lot of cruft (which seems to become the norm nowadays), and while trying to minimized, the bug started occuring intermittently.
Comment 34 Tony Chung [:tchung] 2012-05-03 15:33:04 PDT
testcases found on comment 31 and 33
Comment 35 JP Rosevear [:jpr] 2012-05-08 07:32:56 PDT
Renomming to up the priority to release blocker.
Comment 36 Mark Finkle (:mfinkle) (use needinfo?) 2012-05-08 12:43:49 PDT
*** Bug 751705 has been marked as a duplicate of this bug. ***
Comment 37 Brad Lassey [:blassey] (use needinfo?) 2012-05-21 12:43:37 PDT
Jet, what are the next steps here?
Comment 38 Jet Villegas (:jet) 2012-05-23 11:30:33 PDT
We've got multiple bugs here with different symptoms on ICS vs. older Android versions. I'm currently debugging the non-ICS cases.
Comment 39 Tony Chung [:tchung] 2012-05-31 10:34:33 PDT
(In reply to Jet Villegas (:jet) from comment #38)
> We've got multiple bugs here with different symptoms on ICS vs. older
> Android versions. I'm currently debugging the non-ICS cases.

Hi jet, any progress on this issue yet?
Comment 40 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-06-08 08:18:28 PDT
This works in the current nightly, inexplicably.
Comment 41 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-06-08 08:20:03 PDT
QA, I think some non-mobile change fixed this. We need to figure out if it is still busted in 14 and 15, and if possible find the change that fixed it.
Comment 42 Brad Lassey [:blassey] (use needinfo?) 2012-06-08 08:24:13 PDT
renom'ing. We knocked this off the list because we had no way forward for a fix, which doesn't appear to be true anymore
Comment 43 Mark Finkle (:mfinkle) (use needinfo?) 2012-06-08 11:38:22 PDT
We don't think this should come back to blocking. We should look into the current situation.
Comment 44 Jason Smith [:jsmith] 2012-06-11 01:21:08 PDT
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #41)
> QA, I think some non-mobile change fixed this. We need to figure out if it
> is still busted in 14 and 15, and if possible find the change that fixed it.

Confirmed this is fixed on the current nightly.
Comment 45 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-06-12 06:23:30 PDT
This seems to have been fixed between 2012-06-05 and 2012-06-06:
http://hg.mozilla.org/mozilla-central/rev/a7a905fd70d5
http://hg.mozilla.org/mozilla-central/rev/6338a8988917
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2012-06-04+20%3A00%3A00&enddate=2012-06-06+01%3A00%3A00
Maybe fixed by bug 758361?

I tested this with the unminimized testcase http://people.mozilla.org/~mwargers/tests/unminimized/Studio1290.htm , btw.
Comment 46 Mark Finkle (:mfinkle) (use needinfo?) 2012-06-12 06:30:51 PDT
Bug 758361 is also on Aurora (Fx15). Is this bug fixed on Aurora too?
Comment 47 Aaron Train [:aaronmt] 2012-06-12 06:32:20 PDT
Confirming that Aurora builds currently have the mysterious fix too. Can we narrow it down more?
Comment 48 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-06-12 06:37:29 PDT
Seems to be fixed on Aurora too. I suspect this is bug 758361, but it might just mask this issue.
Comment 49 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-06-12 06:42:11 PDT
Testcase2 is still a problem in current trunk build, so I filed bug 763901 for it.
Comment 50 (Back on May31) Kartikaya Gupta (email:kats@mozilla.com) 2012-06-12 07:18:51 PDT
It seems odd to me that bug 758361 would fix (or mask) this issue. Could you confirm by using the inbound builds?

This one is from 43c1e66ef550 and has bug 758361: http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android/1338827223/
This one is from 8a1829c4f00a and does not have bug 758361: http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android/1338826802/
Comment 51 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-06-12 07:34:37 PDT
Ok, the bug doesn't seem to be there on http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android/1338827223/ , so I guess something else fixed this bug, somehow.
Comment 52 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-06-12 07:45:30 PDT
Hrm, 8a1829c4f00a does show this bug. Are you sure that 8a1829c4f00a does not have  bug 758361 and the bug does show in 43c1e66ef550? Isn't it perhaps the other way around? That the fix is in 8a1829c4f00a and that the bug does show in 43c1e66ef550?
Comment 53 (Back on May31) Kartikaya Gupta (email:kats@mozilla.com) 2012-06-12 08:18:49 PDT
Sorry, I guess I explained myself poorly. By "has bug 758361" I really meant that it has the _patch_ for bug 758361, which in fact means it doesn't have bug 758361. Anyway, if you can reproduce the problem on 8a1829c4f00a but not on 43c1e66ef550, then yes, bug 758361 is what fixed it.
Comment 54 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-06-18 08:28:02 PDT
Comment on attachment 614413 [details]
testcase2

Making obsolete since this testcase has now its own bug, bug 763901.
Comment 55 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-06-18 08:31:50 PDT
I can still reproduce this issue on http://www.huffingtonpost.com/2012/06/14/gretchen-carlson-walks-of_n_1597206.html
So I guess the issue on http://studio1290.com/ is just masked now by the fix for bug 758361.

Note however, you can also reproduce this on http://studio1290.com/ by following the str in comment 6.
Comment 56 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-07-09 09:33:36 PDT
Apparantly Jelly bean works for this site, need to test with ics, gingerbread, froyo.
Comment 57 Aaron Train [:aaronmt] 2012-07-09 09:33:56 PDT
This seems to work fine on my Galaxy Nexus (Android 4.1). I haven't tested 1290 in a few weeks, just re-tested and the videos are working with tap-to-play working. I initially see a white frame, and then the video loads and is playing.
Comment 58 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-07-09 09:58:17 PDT
But this it work with the url and str in comment 55 and comment 6?
Comment 59 Joe Drew (not getting mail) 2012-07-17 13:29:39 PDT
Flash isn't supported on B2G.
Comment 60 Brad Lassey [:blassey] (use needinfo?) 2012-10-04 10:45:11 PDT
What is the status of the evangelism efforts here?
Comment 61 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-10-15 16:52:20 PDT
Based on comment 1, I wasn't aware that there was any evang effort in this bug.
Comment 62 Hallvord R. M. Steen [:hallvors] 2013-08-19 07:41:03 PDT
This is basically a dup of bug 794100. The site uses browser sniffing to white-list a limited number of browsers that get a HTML5 <video>+H.264 experience, all others get Flash (or an error about Flash playing not being available/updated). See follow-up in 794100.

*** This bug has been marked as a duplicate of bug 794100 ***
Comment 63 Hallvord R. M. Steen [:hallvors] 2015-03-29 04:23:01 PDT
Many of the videos on the site are now served by YouTube and these work fine. Some are still served through Brightcove, and these do not work on Firefox Android nor Firefox OS smartphones, because of limitations in the old Brightcove "Smartplayer". We should suggest that the site updates their Brightcove scripts. See https://bugzilla.mozilla.org/show_bug.cgi?id=794100#c30 for details.
Comment 64 Hallvord R. M. Steen [:hallvors] 2015-03-29 04:24:28 PDT
Currently, one example of a video failing to play can be found by scrolling down a bit on the front page to videos by "Wolf Gang". Of course content can be expected to change over time..
Comment 65 Hallvord R. M. Steen [:hallvors] 2015-03-29 04:30:27 PDT
(The URL of that video actually is http://studio1290.com.vip2.535e.blackmesh.com/wolf-gang-back-to-back-studio1290/ )
Comment 66 Adam Stevenson 2016-05-19 12:51:13 PDT
That video WFM on a Nexus 6 in FF49. Hallvord can you confirm?
Comment 67 Mike Taylor [:miketaylr] 2016-05-20 13:53:35 PDT
Yep, Also WFM.

Note You need to log in before you can comment on or make changes to this bug.