Closed Bug 737782 Opened 8 years ago Closed 8 years ago

Keywords added to bookmarks are not saved

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 14
Tracking Status
firefox13 --- verified
firefox14 --- verified
blocking-fennec1.0 --- +

People

(Reporter: AdrianT, Assigned: bnicholson)

References

Details

Attachments

(1 file)

Fennec/14.0a1 2012-03-18
Device: Motorola Droid 2 (Android 2.3)

Steps to reproduce:
1. Load a few websites and add them as bookmarks.
2. Open the Awsomebar and navigate to the Bookmark Tab.
3. Long tap on a Bookmark and choose to edit the bookmark.
4. Add a keyword and tap ok.
5. Open the bookmark edit again to verify the keyword is saved.

Expected results:
The keyword is added to the bookmark.

Actual results:
At step 4 a toaster notification is displayed that the Bookmark has been updated.
At step 5 The keyword field is empty.
Nice catch.

I wonder if the value is saved and is it simply not displayed? Anyways CC'ing Brian, Margaret and Mark.
Blocks: 724194
Severity: major → normal
Version: Firefox 14 → Trunk
Also is this a regression? Did this previously work when bug 723194 landed?
On Nightly/13.0a1 2012-03-12 and the edit bookmark feature was not available. On Nightly/13.0a1 2012-03-13 the feature was introduced but the issue is reproducible and Keywords are not saved. This is not a regression.
Assignee: nobody → bnicholson
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → +
Attached patch patchSplinter Review
We weren't selecting the keyword column in our query, so the keyword column index was returning -1.
Attachment #608539 - Flags: review?(mark.finkle)
Comment on attachment 608539 [details] [diff] [review]
patch

How about a followup bug for testing the edit dialog?
Attachment #608539 - Flags: review?(mark.finkle) → review+
(In reply to Mark Finkle (:mfinkle) from comment #5)
> Comment on attachment 608539 [details] [diff] [review]
> patch
> 
> How about a followup bug for testing the edit dialog?

Filed bug 738519.
https://hg.mozilla.org/mozilla-central/rev/bc2f3408c170
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 14
Verified/fixed on:

Aurora Fennec 13.0a2 (2012-03-25)
Nightly Fennec 14.0a1 (2012-03-25)
Device: Samsung Nexus S
OS: Android 2.3.6
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.