If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Using style opacity on more than one element makes Mozilla crash.

RESOLVED WORKSFORME

Status

Core Graveyard
GFX
--
critical
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: fstmaurice, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; 0.8.1) Gecko/20010323
BuildID:    20001032319

A page containing more than one element using opacity makes mozilla crash when
the page is loaded.

Reproducible: Always
Steps to Reproduce:
1. Insert the following tag more than once in your HTML code:

<IMG style="-moz-opacity: 0.5;" src="http://bugzilla.mozilla.org/ant.jpg"
onMouseover="this.style.MozOpacity=1" onMouseout="this.style.MozOpacity=0.5">

2. Load the page in Mozilla 0.8.1 (works in NS6)


Actual Results:  Mozilla crashes.

Expected Results:  The page should load fine.
(Reporter)

Comment 1

17 years ago
Created attachment 29022 [details]
Testcase of the problem (CRASHER)
(Reporter)

Comment 2

17 years ago
Update: I realized that when I load the testcase from my desktop, It does not
crash. Afterwards, I can access to the testcase with no problem. But if I load
mozilla with a default start page and try to link to it, it crashes. Also, I've
been able to make NS6 crash with the script.

One thing is for sure, if I remove all images but one in the HTML page, no crash
will ever occur.
no crash, linux build 2001-03-28-08
*** Bug 73980 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
With the latest build (April 3rd) , I can't reproduce the crash on either
Windows ME or Mac OS 9.1. Please check with the latest version .
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

17 years ago
I retested the testcase with a clean install of Mozilla 0.8.1, on a new machine.

It does not crash anymore. I suspect that installing 0.8.1 over a version of 0.8
was the source of the problem, because I had other weird behaviours on my
previous machine that do not occur anymore.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.