Last Comment Bug 737892 - Additional cleanup of Thunderbird Test Pilot
: Additional cleanup of Thunderbird Test Pilot
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 14.0
Assigned To: :Irving Reid (No longer working on Firefox)
:
Mentors:
: 738074 (view as bug list)
Depends on: 731532
Blocks: 729127 736984
  Show dependency treegraph
 
Reported: 2012-03-21 08:54 PDT by :Irving Reid (No longer working on Firefox)
Modified: 2012-04-02 10:57 PDT (History)
6 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Resolve more Test Pilot errors/warnings under Thunderbird (17.46 KB, patch)
2012-03-21 09:03 PDT, :Irving Reid (No longer working on Firefox)
no flags Details | Diff | Review
Resolve more Test Pilot errors/warnings under Thunderbird, updated (14.68 KB, patch)
2012-03-28 07:51 PDT, :Irving Reid (No longer working on Firefox)
standard8: review+
Details | Diff | Review

Description :Irving Reid (No longer working on Firefox) 2012-03-21 08:54:42 PDT
+++ This bug was initially created as a clone of Bug #731532 +++

Cleaned up all other warnings in Test Pilot (except one issue, where the "debug.html" page fails when it opens in a tab at TB startup time because the web tab onLoad() is called before Test Pilot is initialized).

As part of this, a touch-up to errUtils.js to make it less likely to throw exceptions when printing events.
Comment 1 :Irving Reid (No longer working on Firefox) 2012-03-21 09:03:20 PDT
Created attachment 607980 [details] [diff] [review]
Resolve more Test Pilot errors/warnings under Thunderbird

Added mail-toolbar to Thunderbird's hiddenwindow.xul so the Test Pilot initializes correctly (and displays menu items correctly) even when all windows are closed on Mac - the "no-windows-open" toolbar includes Tools/Test Pilot as it should.

Cleaned up a couple of other nits, renamed a "window" parameter in several places so it wouldn't be confused for the JS window global, etc.
Comment 2 :Irving Reid (No longer working on Firefox) 2012-03-23 08:12:18 PDT
*** Bug 738074 has been marked as a duplicate of this bug. ***
Comment 3 :Irving Reid (No longer working on Firefox) 2012-03-28 07:51:15 PDT
Created attachment 610133 [details] [diff] [review]
Resolve more Test Pilot errors/warnings under Thunderbird, updated

Slight mid-air collision with bug 739228, updated my patch.
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-03-29 14:18:16 PDT
http://hg.mozilla.org/comm-central/rev/50dfe05b31d6
Comment 5 Philip Chee 2012-03-29 21:12:35 PDT
Are you going to upstream your fixes?
Comment 6 Mark Banner (:standard8) 2012-03-29 23:38:37 PDT
(In reply to Philip Chee from comment #5)
> Are you going to upstream your fixes?

At the moment, the three codebases (FF/Mobile/TB) are diverged, and I believe the core guys are working on re-unifying those. I'm filing bugs on the changes we're making so that they know to pick them up. If folks want to pick those up, that's fine, but we haven't got the time at the moment to do the necessary back-port testing on Firefox and Mobile to ensure the patches haven't broken anything there.
Comment 7 :Irving Reid (No longer working on Firefox) 2012-03-30 06:09:55 PDT
(In reply to Philip Chee from comment #5)
> Are you going to upstream your fixes?

I've been using using Bug 736984 to track Thunderbird changes that may need to be back ported.
Comment 8 Gregg Lind (User Advocacy - Heartbeat - Test Pilot) 2012-04-02 10:57:36 PDT
To clarify.  We have an official 1.2.1 in AMO that reflects what the "firefox" build should look like.  We are going to roll in tbird changes (from this patch and others) in the next week or two, then hopefully the codebases will be unified :)  standard8, let's talk details about what fits best into your flow soon!  (offline, not in this bug!)

Note You need to log in before you can comment on or make changes to this bug.